Author Topic: Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'  (Read 15082 times)

0 Members and 1 Guest are viewing this topic.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #30 on: December 06, 2004, 04:46:43 PM »
I'm just saying that the error can be in xfire - because the DLL it loaded into avast!.
Anyway, can you send me the DLL? I'm not saying I'll find the cause, but it would certainly help.

thenicestguy23

  • Guest
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #31 on: December 09, 2004, 09:11:28 AM »
You can view previous posts in this thread, I put a download link in 1 of them for this DLL file, but you have to right click on link and choose "Save Target As..." in order to download (for some strange reason) or choose "copy shortcut" then paste link in browser.

I re-post link here.

Download xfire_conure_10406.dll File

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #32 on: December 09, 2004, 04:11:35 PM »
Ah, sorry, I didn't notice the link.

I checked the DrWatson dump and the file... but I don't really know where the problem is. The crash occurred in the xfire.dll after avast setup(01) has finished. So, if the xfire.dll wasn't there, avast setup would simply terminate; in this case, however, the DLL craches during its detachment from the avast process.

So, I think it's rather a problem of xfire. However, I don't know in detail what the DLL really does in the moment it crashes, so I cannot say much more.  :-\

thenicestguy23

  • Guest
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #33 on: December 10, 2004, 02:39:41 AM »
well, I as I stated before, it has to do with setting your idle status for xfire.  Are you sure it does it ONLY during shut down of Avast01 and not during start up of Avast01??

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #34 on: December 10, 2004, 10:17:14 AM »
well, I as I stated before, it has to do with setting your idle status for xfire.

Well, by "in detail" I meant that I don't know what is happening in the particular piece of code where it crashes. Xfire is deallocating a list of something there - and it accesses an incorrect place in memory. But what is stored inside of the list and why it looks where it shouldn't... no idea.

Are you sure it does it ONLY during shut down of Avast01 and not during start up of Avast01??

I am talking about that one DrWatson dump you sent me - in that case, the crash occurred after avast process has stopped and the DLL was detaching from it.

thenicestguy23

  • Guest
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #35 on: December 10, 2004, 08:34:26 PM »
Basically I just need to know if it is Xfire problem to fix or something you can fix on your end??  If xfire is accessing incorrect place in memory, then it is totally xfire's fault (at least in my opinion).  Hence why I get the BSOD sometimes(blue screen of death).  As far as I know, the reason you get the BSOD error messages (besides the VxD errors) is because a program that was running accesses memory incorrectly and doesn't have the code built into the program to recover from the error, so then windows OS tries to recover from the error, and if it can't recover from the error, then you get the infamous BSOD.  I think it is screwed up xfire files in my opinion, but don't know much about the xfire code nor the avast code.

Would more Dr. Watson logs help you???

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11865
    • AVAST Software
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #36 on: December 13, 2004, 05:47:18 PM »
If you have some more dumps, you can send them to me.
At least I could say if the problem is always the same.


thenicestguy23

  • Guest
Re:Avast 4.5--Avast01 caused error in 'XFIRE_CONURE_10226.DLL'
« Reply #37 on: December 15, 2004, 11:34:40 PM »
I am at work now, but I will start dr Watson tonight and give u a couple of the newest logs.


EDIT: (Sat. 12/18)  Igor, I sent you 2 Dr. Watson logs generated today.  Please check your inbox.
« Last Edit: December 18, 2004, 09:48:26 PM by thenicestguy23 »