Author Topic: Avast update changed the mail settings  (Read 2932 times)

Offline Bob23456

  • Jr. Member
  • **
  • Posts: 27
    • Personal Message (Offline)
Avast update changed the mail settings
« on: January 27, 2012, 02:39:35 PM »
I could not get email, in avast email settings it changed the POP3 server to port 995 from 110 which my email uses, and turned TLS on for SMTP and SSL on for POP3.
Only since I got the update of virus definitions why would it do this?
It took me 2 hours to figure it out.
« Last Edit: January 27, 2012, 02:41:57 PM by Bob23456 »

Offline DavidR

  • avast! √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 69240
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
Re: Avast update changed the mail settings
« Reply #1 on: January 27, 2012, 03:16:27 PM »
The VPS shouldn't do anything to the avast, Mail Shield, Expert Settings, SSL account, settings either, so this seems to be an unfortunate coincidence.

The main thing is that in your email program email account settings you don't have any SSL/encryption enabled or avast can't scan the content. You could then safely delete the incorrect entries for those accounts in the Mail Shield, Expert Settings, SSL account and reboot that would recreate the SSL account entries.

What you don't say is ordinarily does your email account use SSL for POP3 and SMTP ?
As that would determine what ports the Mail Shield, Expert Settings, SSL account, would use.

On all of my POP3 account entries (5 of them) all are set to port 110 and none have been changed to port 995.

If your email account uses SSL ordinarily for POP3 then port 995 in the Mail Shield, Expert Settings, SSL account, settings would be correct.
- avast! 6.x: SSL Problems The Mail Shield may not scan some e-mails - see https://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=842.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2018/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Nolow

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: Avast update changed the mail settings
« Reply #2 on: January 27, 2012, 03:18:28 PM »
My Avast did something similar today.
>>Avast! - has detected a secure connection for your mail program
This type of connection cannot be checked for viruses.  Please disable
SSL/TLS in your mail client so that the Mail Scanner will provide the
SSL/TLS security itself.

The program I was using was windows live mail, after this popped up I clicked ok. Ever since then I cannot send any kind of email --I use Yahoo mail-- I can't even save a composed message to my draft folder now. Can anyone help me? [I need to fix this ASAP, I have to email a quiz to my professor.]

Offline DavidR

  • avast! √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 69240
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
Re: Avast update changed the mail settings
« Reply #3 on: January 27, 2012, 03:25:30 PM »
Similar but not the same, so you ideally should start your own new topic.

If the receiving email server requires a secure connection and you have it enabled in your email program this is what avast will throw up as it can't scan secure connections (that is the whole point of SSL). So you have to disable it within the email program and allow avast to handle it. Read the information contained in the link I gave in my last post.

If you need to ask further questions it should be done in its own topic so as not to hijack this one.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2018/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Bob23456

  • Jr. Member
  • **
  • Posts: 27
    • Personal Message (Offline)
Re: Avast update changed the mail settings
« Reply #4 on: January 28, 2012, 01:31:08 AM »
The VPS shouldn't do anything to the avast, Mail Shield, Expert Settings, SSL account, settings either, so this seems to be an unfortunate coincidence.

The main thing is that in your email program email account settings you don't have any SSL/encryption enabled or avast can't scan the content. You could then safely delete the incorrect entries for those accounts in the Mail Shield, Expert Settings, SSL account and reboot that would recreate the SSL account entries.

What you don't say is ordinarily does your email account use SSL for POP3 and SMTP ?
As that would determine what ports the Mail Shield, Expert Settings, SSL account, would use.

On all of my POP3 account entries (5 of them) all are set to port 110 and none have been changed to port 995.

If your email account uses SSL ordinarily for POP3 then port 995 in the Mail Shield, Expert Settings, SSL account, settings would be correct.
- avast! 6.x: SSL Problems The Mail Shield may not scan some e-mails - see https://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=842.
I am using Avast AV 6.0.1203.
No I have never had any SSL enabled in outlook express.
All I did was change in Avast mail shield expert settings the SMTP and POP3 to the correct port and none for encryption and it worked.
But I have been using avast for years and never have had to do this.
I was using a program called Spamihilator which I removed because I thought that was causing my email to not work, but I just reinstalled that and its working fine.
It was avast, and for some reason randomly changed my email settings to SSL and TLS and using 995 for POP3 port.
It is strange it would randomly change this, and it only happened after the update of definitions as I said.
« Last Edit: January 28, 2012, 01:49:00 AM by Bob23456 »

Offline Bob23456

  • Jr. Member
  • **
  • Posts: 27
    • Personal Message (Offline)
Re: Avast update changed the mail settings
« Reply #5 on: January 28, 2012, 01:47:20 AM »
My Avast did something similar today.
>>Avast! - has detected a secure connection for your mail program
This type of connection cannot be checked for viruses.  Please disable
SSL/TLS in your mail client so that the Mail Scanner will provide the
SSL/TLS security itself.

The program I was using was windows live mail, after this popped up I clicked ok. Ever since then I cannot send any kind of email --I use Yahoo mail-- I can't even save a composed message to my draft folder now. Can anyone help me? [I need to fix this ASAP, I have to email a quiz to my professor.]
Its easy to fix although it clearly shouldn't be behaving this way.
Just check your account settings in Windows Live Mail for your accounts.
Write down the SMTP port and POP3 port and server name listed in your settings.
And go into avast expert settings and change the info to match your client and accounts.

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8800
  • Gender: Male
    • Personal Message (Offline)
Re: Avast update changed the mail settings
« Reply #6 on: January 28, 2012, 01:44:59 PM »
I am using Avast AV 6.0.1203.
Why are you not using the latest avast! v6.0.1367 ???
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now