Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Romagnolo1973 on December 31, 2013, 07:51:36 PM

Title: Avast Free + PrivateFirewall= black screen at start
Post by: Romagnolo1973 on December 31, 2013, 07:51:36 PM
this combo has some problems.
This appens with PF 7.0.30.3 (last available) on my win8.1 64bit and for other italians user with win7 64bit
Starting the pc it boots perfectly but when is time to show your desktop screen it remain black and you can only force restart 2 or 3 times untill desktop is showed. Sometimes screen is black but you can see mouse arrow.
I have startet a post on Wilder's about this issue and for me is 100% Avast problem
Look here
http://www.wilderssecurity.com/showthread.php?p=2323203#post2323203
Please avast devs investigate more
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: jacemace5005 on December 31, 2013, 08:34:57 PM
Just as a poster who replied to you noted in Wilders, it is Avast Emergency update and the runonce command.
If you can open your task manager, you will probably notice under Processes tab that the Disk is at 100%.
I had avast emergency update (32bit) in the background processes running the disk high in multiple instances.
Interestingly, there was also a Windows process that was occurring with this.
The emergency update is explained here in the Ghacks website http://www.ghacks.net/2012/06/30/avast-update-brings-emergency-updater-and-sitecorrect-features/

Some say you can disable it, but most say to let it be.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: jwoods301 on December 31, 2013, 09:35:05 PM
Try adding the "emupdate" folder to the exclusions list in your firewall program.

Path is Program Files\AVAST Software\Avast\setup\emupdate
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 01, 2014, 05:51:30 AM
You cannot add to Privatefirewall's exclusion list an entire folder.And those 2 exe's from that folder are whitelisted already in Privatefirewall.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: jwoods301 on January 01, 2014, 06:08:35 AM
Except that the names of those .exe's change...

There should be a "Trusted Vendor" setting (most firewalls have that).

Add Avast to that list and use AvastEmUpdate as the signed .exe.

Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 01, 2014, 08:37:31 AM
AvastEmUpdate is still blocked by MVPS Hosts files (and other hosts lists) .......... they said it would be sorted out last week.

I have a rig using Private firewall and just got so fed up with avast and this nonsense, I ripped it out and changed AV vendor , end of issue.



Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: dfxbb on January 01, 2014, 11:55:13 AM
Same problem here.

Don't have to reboot, just Ctrl-Alt-Del, logout and then login again.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: NoelC on January 01, 2014, 02:46:43 PM
AvastEmUpdate is still blocked by MVPS Hosts files (and other hosts lists) .......... they said it would be sorted out last week.

I realize you may not be back, given that you've "switched brands", but what specifically did you do/see to detect this?

I rebooted Windows 8.1 on the 28th and had no problem whatsoever in getting back to an operational status; it just booted right up.  The GUID-named emergency updater ran, the RunOnce registry entry was removed, and the software says it's up to date. 

I did notice a new GUID-named emergency updater has reappeared in a RunOnce entry.  I'm led to believe that's perfectly normal to see, and doesn't imply anything's out of date or in crisis.

-Noel
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 01, 2014, 02:54:01 PM
Except that the names of those .exe's change...

There should be a "Trusted Vendor" setting (most firewalls have that).

Add Avast to that list and use AvastEmUpdate as the signed .exe.
Avast it's already there.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Gopher John on January 01, 2014, 04:33:24 PM
AvastEmUpdate is still blocked by MVPS Hosts files (and other hosts lists) .......... they said it would be sorted out last week.

I have a rig using Private firewall and just got so fed up with avast and this nonsense, I ripped it out and changed AV vendor , end of issue.

For me, AvastEmUpdate and the MVPS Hosts file issue has cleared up within the past week.  The emergency updates have been applied, and there are no stray pending emergency updates now.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: jwoods301 on January 01, 2014, 08:30:32 PM
Except that the names of those .exe's change...

There should be a "Trusted Vendor" setting (most firewalls have that).

Add Avast to that list and use AvastEmUpdate as the signed .exe.
Avast it's already there.

You may wish to submit a support ticket to Avast...

https://support.avast.com/Tickets/Submit (https://support.avast.com/Tickets/Submit)

I use COMODO 6.3 free firewall with Avast free AV and don't have any issues.


Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Para-Noid on January 01, 2014, 09:46:48 PM
Within the past year quite a few users have switched from PFW to either Comodo Firewall or Online Armor.
Personally I prefer CFW v5.12 which has fewer issues than v6.0, 6.1, 6.2 or 6.3. v5.12 also has a smaller
footprint and uses less resources.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 02, 2014, 08:57:17 AM
Last night I looked at this again.

I set Private Firewall to training mode and " ask" for all processes.

Installed avast9  ( I used the AIS install, but only selected antivirus, safezone and program updater.)

Install progressed and Private Firewall asked permissions for numerous processes.

Restarted / full shutdown and start many times now ,without any issues.

Win8.1 64Bit .  Acer laptop, Bitlocker.PF. Malwarebytes Pro.

Avast is in the Trusted Publisher list and the processes shown in the image are set to " Filter" within process control.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 02, 2014, 12:56:25 PM
Quote
You may wish to submit a support ticket to Avast...

https://support.avast.com/Tickets/Submit

I use COMODO 6.3 free firewall with Avast free AV and don't have any issues.
I hope that someone from Avast is reading this thread already,no need for another one on the same subject.But thanks for the suggestion.I would use CFW too,but in combo with Avast i get high CPU usage from Comodo.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 02, 2014, 01:09:56 PM
I have installed avast Free and Private Firewall on a Win81 desktop this morning......... there is no problem.

Just make sure Private Firewall has permissions for all the avast processes.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Para-Noid on January 02, 2014, 09:28:10 PM
Quote
You may wish to submit a support ticket to Avast...

https://support.avast.com/Tickets/Submit

I use COMODO 6.3 free firewall with Avast free AV and don't have any issues.
I hope that someone from Avast is reading this thread already,no need for another one on the same subject.But thanks for the suggestion.I would use CFW too,but in combo with Avast i get high CPU usage from Comodo.

CFW v5.12 does not use as much CPU resources as v6.x  :)
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: jwoods301 on January 02, 2014, 09:44:49 PM
Quote
You may wish to submit a support ticket to Avast...

https://support.avast.com/Tickets/Submit

I use COMODO 6.3 free firewall with Avast free AV and don't have any issues.
I hope that someone from Avast is reading this thread already,no need for another one on the same subject.But thanks for the suggestion.I would use CFW too,but in combo with Avast i get high CPU usage from Comodo.

CFW v5.12 does not use as much CPU resources as v6.x  :)

Using Sysinternals.com's Process Explorer, all COMODO 6.3 processes on my system show minimal use of memory and CPU.

Again, I think that's because each system is configured differently.

Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Arnold72 on January 02, 2014, 10:43:02 PM
From personal experience privatefirewall is a terrible program.In fact the worst piece of rubbish i ever installed.Use comodo firewall 5.12 which is a far better firewall.Or use online Armor which is another superb firewall.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AliveinIdaho on January 02, 2014, 11:16:56 PM
First time posting, so if I get something wrong be patient.

Windows 7 Sp1 (updated)
Avast Free - 2014.9.0.2011
Private Firewall 7.0.30.3

Have this setup running on my backup rig and was experiencing the black screen that is referred to.  Went to control panel and did Avast repair and rebooted and once again all is right with the world.  Don't know if this will work for all, but for me it was quick, simple and no headaches.

A.T.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 03, 2014, 09:39:59 AM
From personal experience privatefirewall is a terrible program.In fact the worst piece of rubbish i ever installed.Use comodo firewall 5.12 which is a far better firewall.Or use online Armor which is another superb firewall.

Each to their own ........ PF is an industry grade firewall that is used on servers as well as desktops, and is very highly rated. Perhaps you just didn't understand the program and how powerul it is?

I wouldn't touch Comodo or Online Armor, based on my experience and that seen on the 1000's of machines through the workshops .....


As it is this thread is about Private Firewall, not Comodo or Online Armor.

Fact is if correctly installed Avast9 and Private Firewall work perfectly on Win8 and provide a very high level of security.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 03, 2014, 02:02:07 PM
From personal experience privatefirewall is a terrible program.In fact the worst piece of rubbish i ever installed.Use comodo firewall 5.12 which is a far better firewall.Or use online Armor which is another superb firewall.

Each to their own ........ PF is an industry grade firewall that is used on servers as well as desktops, and is very highly rated. Perhaps you just didn't understand the program and how powerul it is?

Have to agree on this one.I simply love this firewall.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Cast on January 04, 2014, 03:44:09 AM
I would also have to agree about PF I like it, my only complaint about it would be the symbol used in the tray that looks outdated.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 22, 2014, 04:44:08 PM
10 minutes ago at start up it happened again,the very same issue.I had to manually kill that runonce.exe process as "usual"...
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: bollity on January 22, 2014, 06:35:27 PM
I have this problem too. I have avast + comodo firewall.
Please remove emergency update it is not necessary.Keep avast simple or you will loose a lot of users.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: cavehomme2 on January 22, 2014, 07:15:15 PM
From personal experience privatefirewall is a terrible program.In fact the worst piece of rubbish i ever installed.Use comodo firewall 5.12 which is a far better firewall.Or use online Armor which is another superb firewall.

In my own tests I have found PFW to be capable of catching most threats even without an AV switched on. It uses very few resources and with a bit of initial tweaking of alerts just does its job quietly in the background. I contrast that positive experience to CFW which is quite the opposite. On a day to day basis I no longer use either because I feel safe enough behind my hardware firewall as well as a great anti-virus, sadly no longer Avast.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 22, 2014, 08:07:46 PM
avast and PFW running here without any issues.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: kaninus on January 24, 2014, 07:05:52 AM
Also got this issue with the Avast + Comodo combination on a freshly installed Windodw 7 x64 computer. Black screen after login. The only thing visible on screen is the mouse cursor.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: newhere2 on January 24, 2014, 07:40:24 AM
i have the avast and comodo firewall (only firewall) updated and when emergency updates starts on logon i have to kill runonce.exe or restart 3 times for it to stop doing this.
then i have 1-2 months of piece before avast does it again.
seems like its avast's fault, PFW and now comodo, well done avast.

at least im happy to see im not the only one having this, i suspected avast in the past but now i know i was right!!
windows 7 sp1 64bit
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 24, 2014, 08:17:06 AM
i have the avast and comodo firewall (only firewall) updated and when emergency updates starts on logon i have to kill runonce.exe or restart 3 times for it to stop doing this.
then i have 1-2 months of piece before avast does it again.
seems like its avast's fault, PFW and now comodo, well done avast.

at least im happy to see im not the only one having this, i suspected avast in the past but now i know i was right!!
windows 7 sp1 64bit

and yet other people using the exact same combinations of security have zero issues .............  avast/PFW work without any of these problems for me.

Maybe your firewall settings are incorrect.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 24, 2014, 11:47:20 AM
i have the avast and comodo firewall (only firewall) updated and when emergency updates starts on logon i have to kill runonce.exe or restart 3 times for it to stop doing this.
then i have 1-2 months of piece before avast does it again.
seems like its avast's fault, PFW and now comodo, well done avast.

at least im happy to see im not the only one having this, i suspected avast in the past but now i know i was right!!
windows 7 sp1 64bit

and yet other people using the exact same combinations of security have zero issues .............  avast/PFW work without any of these problems for me.

Maybe your firewall settings are incorrect.
The problems is clearly Avast's,it's hard to believe that we all who reported this problem are newbies and don't know how to use a properly configured firewall.PWT and Comodo,that's clearly not a coincidence.And again,i'm using Privatefirewall for more than 2 years (with Panda Cloud,AVG,Avira,Bitdefender AV Pro) and i NEVER faced something like this.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: newhere2 on January 24, 2014, 12:25:01 PM
i have the avast and comodo firewall (only firewall) updated and when emergency updates starts on logon i have to kill runonce.exe or restart 3 times for it to stop doing this.
then i have 1-2 months of piece before avast does it again.
seems like its avast's fault, PFW and now comodo, well done avast.

at least im happy to see im not the only one having this, i suspected avast in the past but now i know i was right!!
windows 7 sp1 64bit

and yet other people using the exact same combinations of security have zero issues .............  avast/PFW work without any of these problems for me.

Maybe your firewall settings are incorrect.
The problems is clearly Avast's,it's hard to believe that we all who reported this problem are newbies and don't know how to use a properly configured firewall.PWT and Comodo,that's clearly not a coincidence.And again,i'm using Privatefirewall for more than 2 years (with Panda Cloud,AVG,Avira,Bitdefender AV Pro) and i NEVER faced something like this.
just ignore adrian, avast is the problem its a fact not an opinion.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Romagnolo1973 on January 27, 2014, 04:55:12 PM
We decect the issue: emergency updates starts at logon conflicts with some third parties FW (PF, CIS and I think others) but Avast devs seems silents.
More than evidence the problem we can't do, or we can do just a thing: change Av
I think next time emergency update start at logon the problem return because is not solved
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on January 28, 2014, 04:43:14 PM
Yes,it seems odd that nobody from Avast doesn't seem present and don't reply a few words about this issue.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: NoelC on January 29, 2014, 06:30:42 PM
Out of curiosity - and this is NOT a criticism, just an attempt to understand:  What do these 3rd party firewalls bring to the party that Windows' firewall doesn't?

I'm just curious why people use them.

-Noel
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: CraigB on January 29, 2014, 06:32:41 PM
Out of curiosity - and this is NOT a criticism, just an attempt to understand:  What do these 3rd party firewalls bring to the party that Windows' firewall doesn't?

I'm just curious why people use them.

-Noel
Ease of use/configuration and Hips, blocking lists.
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: Johnnyy on January 31, 2014, 07:11:59 AM
The same problem: avast 2014.9.0.2013 + comodo 6.3.302093.2976.
Black screen on windows startup. I need to kill explorer process and run it again for desktop show, but no autorun programs start, so i need to reboot my pc and the everything strating fine.
For now i delete trigger "Run on user logon" in scheduler for "avast! Emergency Update".
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: AdrianH on January 31, 2014, 04:07:05 PM
The same problem: avast 2014.9.0.2013 + comodo 6.3.302093.2976.
Black screen on windows startup. I need to kill explorer process and run it again for desktop show, but no autorun programs start, so i need to reboot my pc and the everything strating fine.
For now i delete trigger "Run on user logon" in scheduler for "avast! Emergency Update".

This thread is about Private Firewall, not Comodo.

Try here >> http://forum.avast.com/index.php?topic=145293.0
Title: Re: Avast Free + PrivateFirewall= black screen at start
Post by: JoeBlack40 on February 08, 2014, 06:54:16 PM
Out of curiosity - and this is NOT a criticism, just an attempt to understand:  What do these 3rd party firewalls bring to the party that Windows' firewall doesn't?

I'm just curious why people use them.

-Noel
Ease of use/configuration and Hips, blocking lists.
Exactly,100% agree.