Poll

Have you experienced download problems with WebShield? Did it get any better after this fix.

No apparent download issues, before or after.
43 (39.4%)
I do have some issues, running XP or Vista, no change after the fix.
3 (2.8%)
I do have some issues, running Windows 7 or 8, no change after the fix.
39 (35.8%)
I had some issues, running Windows 7 or 8, issues are gone after the fix.
12 (11%)
I do have some issues, don't know if I have the fix or not.
12 (11%)

Total Members Voted: 0

Author Topic: Fix for WebShield download issues  (Read 102175 times)

0 Members and 1 Guest are viewing this topic.

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #150 on: January 29, 2014, 01:06:50 AM »
Lukas,

I just saw the message you sent. Thank you. I will consider capturing the logs, but it's difficult for me to justify spending additional time on this issue, as I simply don't have the time.

Thank you again for your attempts to help.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #151 on: January 29, 2014, 01:17:24 AM »
Lukas:

1. You sent the step by step info after the first folder I uploaded did not work.
The second time I uploaded it and the logs were not useful to you.
The third time I uploaded the logs after replicating the download problem a second time, and unless there are more instructions on how to upload a folder through ftp (even though it seems you've received the files) I don't understand what instructions you're referring to.



Haven't you received an IM from me a few hours ago?

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #152 on: January 29, 2014, 02:13:42 AM »
Lucern,

we are really working on the issues with WebShield, we have solved many of them and made it work much better for many users. We have released a version update, because we considered the issues important. All of the issues we saw and been able to reproduce either in our lab or with our users were fixed.

I am really sorry, your's wasn't among the fixed ones, this however does not mean we don't care and even up to the point, that me and other developers would rather work on it in their free time (at nights).

I appreciate your effort with the logs. Thank you for that and sorry for not stressing that more in my previous messages.

Since it didn't help us find the cause, and since you've already spent quite some time with it, I guess it is the right time to switch to the proxy mode. I still can not understand why are you against such solution. You can change the number from 0 to 1 and back anytime you want - it is nothing permanent. It does not mean we wouldn't continue searching for bugs in streamfilter part of the WebShield and it will also help us identify if at your's case this helps or not.

Lukas.

PS:one last comment, the streamfilter was released 18th of December. It's only about one month since that, that is why I have a tendency to over react to statements that this or this is part of the same bug for months.

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #153 on: January 29, 2014, 08:52:13 AM »
Lukas,

Thank you, I am sorry the logs weren't more helpful. I truly appreciate the work that developers like yourself do to maintain Avast, and understand your dedication to your users. I understand that your team released the December patch very quickly, and it fixed most users' problems, and you should all be highly commended for your work. I apologize if my frustrations with the problems I have personally encountered came across as too aggressive. It was not my intention.

Earlier today, I decided to try uninstalling and reinstalling Avast, just to see if that would help. I used the Avast Removal Tool in safe mode.
I apologize in advance for what I'm about to write next, as it's going to sound like I am making it up. So, you only have my word, and I understand if it sounds far-fetched.

After uninstalling in safe mode, rebooting, and installing Avast, the program caused my internet as whole to become unresponsive. No webpages would load. They all timed out. When I tried to turn the Web Shield off, the entire Avast program froze. I've no idea why or what caused such behavior. I tried closing and reopening the program several times, but on subsequent times the program would freeze on launch.

I was eventually able to turn the web shield off, but now even doing that didn't change anything. Nothing in-browser would load.

I gave one last try by uninstalling through the control panel, rebooting, and installing Avast again. The same problems persisted - no webpages would load, and Avast would freeze if I tried to launch it.

Unfortunately, I am unable to continue troubleshooting with you, due to Avast not seeming to work on my computer anymore. :( I'm currently using a different AV program installed that is allowing me to use my computer normally again.

I am glad that these issues at least don't appear to be widespread. I know your team will be able to isolate the problem, and I hope to be able to use Avast once again in the future.

Thanks again for your assistance.
« Last Edit: January 29, 2014, 09:00:58 AM by lucern »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #154 on: January 29, 2014, 11:11:52 AM »
That's really scary, what you have just described. sorry for that.
We'll try to retest the safe-mode uninstall scenario you have used. So far I have no idea what could have caused such a massive problem.
 
Thanks, and sorry again. Definitely something on your PC that avast! really hates!  :'(
 
Hope to see you again someday in the future.
Bye.
Lukas.
 

Offline Zdenek

  • Avast team
  • Jr. Member
  • *
  • Posts: 38
Re: Fix for WebShield download issues
« Reply #155 on: January 29, 2014, 03:39:47 PM »
Hallo,

I have found that issue with corrupted downloads has been reported to Microsoft and then Microsoft has released a hotfix for that problem. You can find the hotfix here:

http://support.microsoft.com/kb/2789397/en

I can ask all users affected by the problem to try if it helps or not.

Additionally, We will appreciate if you can provide exact version of your OS (Version, service pack and platform(x32/x64), plus information about your network card.

Zdenek


Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #156 on: January 29, 2014, 08:09:00 PM »
Hi,
it really seems that the hotfix mentioned by Zdenek might be a cause for several issues. I have a request, could you guys - anyone with the problem, but especially Lucern (if you are still with us at least via the forum - sorry for bothering you again) run the following command to list the installed hotfixes on your system.


1. click Start \ Run (or Win+R if you are on Windows 8 )
2. type:
Quote
systeminfo >%userprofile%\desktop\systeminfo.txt


3. send us the file systeminfo.txt created on your desktop. You can send it directly to me via email to rypacek (at) avast.com


Thank you very much, guys.


Lukas.

stephenavast

  • Guest
Re: Fix for WebShield download issues
« Reply #157 on: April 25, 2014, 11:58:26 PM »
I last posted on this thread on 30th December 2013 - the issue still stands! When WebSheild is enabled, my fiance's window 7 laptop cannot access the internet, IE just spins around (egg timer equivalent) and doesn't load correctly. When I disable WebSheild, access is instant regained and the laptop acts properly. So, for the last 3 months, I've simply disabled WebSheild.

On a prompt today, I updated Avast on her lap top to version ending in 2014. Exactly the same issue - websheild on, no internet, websheild off, internet just fine.

Now, as stated before, I'm no computer geek, so without asking me to rebuild the laptop, change the registry etc etc, is there a simple way to fix this issue? (I was hoping that loading the update, that you would have repaired Avast by now)...

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #158 on: April 26, 2014, 12:01:50 AM »
Hi, the latest version is 9.0.2018.

Lukas

stephenavast

  • Guest
Re: Fix for WebShield download issues
« Reply #159 on: April 26, 2014, 12:14:17 AM »
Apologies, my bad. That is exactly the update I've installed, and it still doesn't work...

TFC

  • Guest
Re: Fix for WebShield download issues
« Reply #160 on: April 28, 2014, 03:15:20 AM »
I am experiencing the  problem where the browser does not always load web pages. Sometimes nothing appears. Other times some of the page appears, but in both cases the spinning status symbol continues to spin, with the browser waiting for the remainder of the message. It can only be cured by stopping the page transfer, and then refreshing the page.

It is affecting mostly https:// pages.  The problem is consistent with certain web sites. Other websites are problem free, even with https:// pages.

I am using Windows 8.1, completely up to date and using Avast 9.0.2018.

When Webshield is switched off I don't have a problem. I have tried switching off just the script scanning, but this does not solve the problem. When I have tested this problem I have cleared the browsers cache before each test, to make sure the conditions are the same.

I have done some monitoring with Microsoft Network Monitor V3.4, and there seem to be 'Segment lost' messages coming back from the server, when the problem occurs. I have collected and saved the .CAP (capture) file.

I was going to attach the .CAP file collected when the problem occurred. Unfortunately, I can't as the forum doesn't allow such attached files.

Is there any way I can get the file to someone who could analyse and diagnose the problem from here? (The file is 178KB .CAP file.)

stephenavast

  • Guest
Re: Fix for WebShield download issues
« Reply #161 on: April 28, 2014, 12:35:33 PM »
Hi,

I had a lovely PM from a 'developer' offering to investigate my issue but requires me to send him a 'binary file'. Just to let him know (Zdenek) that although I can apparently receive PMs, I am 'unallowed' to send one! If you can get a forum mod to let me send them I'll gladly send you the file. Thank you, stephen

TFC

  • Guest
Re: Fix for WebShield download issues
« Reply #162 on: April 28, 2014, 01:07:07 PM »
Yes, I have literally 'just' found the same problem.

I can't send anything either. Not even a reply!

TFC

  • Guest
Re: Fix for WebShield download issues
« Reply #163 on: April 28, 2014, 01:45:56 PM »
Hi Zdenek,

Can't reply via PM, so here is the information.

The Details tab in the Properties tab for the aswstm.sys file (which is in my C:\Windows\System32\Drivers folder) tells me the following :-

File description:   Stream filter
Type:   System file
File Version:   9.0.2018.391
Product name:   avast! Antivirus
Product version:   9.0.2018.391
Copyright:   Copyright (c) 2013 AVAST Software
Size:   66.1 KB
Date Modified:   22/04/2014 08:27
Language:   English (United States)
Original filename:   aswStm.sys

The checksums are :-

 File: aswstm.sys
CRC-32: 183ffb52
   MD4: 3159867e85416424bb1ed1008182d679
   MD5: e458d8d20af6fe3f4784c18e8a1f02c3
 SHA-1: f27410d79df5f0d4089e7b27d611e0b770d3c387

I have attached a copy of the .CAP file encoded with a Base64 converter which I used at
the site http://www.motobit.com/util/base64-decoder-encoder.asp
(I have tested that the file attached does decode to produce an exact binary copy of the original .CAP file, and that the resultant .CAP file is still acceptable to the Microsoft Network Monitor.


Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 47050
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Fix for WebShield download issues
« Reply #164 on: April 28, 2014, 02:26:42 PM »
PM'S require 20 forum posts. It's an anti spam measure.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast One 21.11, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://bi