Poll

Have you experienced download problems with WebShield? Did it get any better after this fix.

No apparent download issues, before or after.
43 (39.4%)
I do have some issues, running XP or Vista, no change after the fix.
3 (2.8%)
I do have some issues, running Windows 7 or 8, no change after the fix.
39 (35.8%)
I had some issues, running Windows 7 or 8, issues are gone after the fix.
12 (11%)
I do have some issues, don't know if I have the fix or not.
12 (11%)

Total Members Voted: 0

Author Topic: Fix for WebShield download issues  (Read 99653 times)

0 Members and 1 Guest are viewing this topic.

HA Nut

  • Guest
Re: Fix for WebShield download issues
« Reply #30 on: December 22, 2013, 03:23:21 PM »
I voted for " No apparent download issues, before or after ". However, I've tried to recreate aswstm.sys following lukor's procedure without positive results. I've even waited 15 min, but the new file does not show. I will wait for the EmUpadate.

Does this patch ( procedure ) also apply for Windows XP_86 ?

Was the same for me. But there does seem to be a solution.

As noted in the build 2011 thread, the issue seems to be running a managed HOSTS file. (I use the MVPS HOSTS file.) Once I temporarily renamed it, the new aswstm.sys showed up fairly quickly.

To Avast:

Please publicly let us know what domain(s) is the issue with Avast and a HOSTS file that is used to block ads, browsing analytics and so forth. This would give us the option of modifying our HOSTS file if we wish to do so. (Why you would need to track us for this is beyond me but clearly this is the issue at hand.)

Telegraph_Sam

  • Guest
Re: Fix for WebShield download issues
« Reply #31 on: December 22, 2013, 10:15:34 PM »
"The block could of course be due to something completely unrelated, but that would be a coincidence. 
Is there no one else reading this who uses Yahoo Mail together with 32-bit XP and who has, or has not had these download problems, and if so with what settings??? :'( "    [This is my own quote - is this allowed?!]

I haven't had time to check this out properly - yet - but it could be that the download block, the way I've got the system set up, kicks in when I'm using Chrome, but not if I switch to IE.  Any logic in this, if true?

Capp

  • Guest
Re: Fix for WebShield download issues
« Reply #32 on: December 24, 2013, 03:39:53 AM »
I am apparently a late adopter, I just got this problem today.  I upgraded my Avast! this afternoon but didn't use the computer immediately, hence I didn't relate my later-discovered dead internet connection with Avast until now.  (It would work for a couple minutes after each reboot so I managed to get a couple web searches done and figure out it was Avast.)

Because I upgraded "late" the "fixed" files must have installed right along with the upgrade itself for me (I'm assuming the version numbers of those two files pre-fix were different than the "fixed" files.) so I never had this upgrade version without them... and yet I have the problem. :/

So now that I know what's doing it I decided to test:  Web Shield Off = completely normal I even ran a speed test, full speed.   Turn Web Shield On, the speed test kills the internet connection instantly, it can't get past the ping portion before the connection is dead.  So my problem must be the Web Shield, even though I have the "fix." 

I'm running Windows 7, BTW.  (64 bit if it helps)


Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1886
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #33 on: December 24, 2013, 11:38:09 AM »
Could you please post a version info of the aswstm.sys file inside c:\Windows\system32\drivers? Just to be sure the fix had been correctly applied.

Capp

  • Guest
Re: Fix for WebShield download issues
« Reply #34 on: December 24, 2013, 03:59:40 PM »
Could you please post a version info of the aswstm.sys file inside c:\Windows\system32\drivers? Just to be sure the fix had been correctly applied.

Ahhh.  In the system folder it's 9.0.2011.263 not the .265 that's in the Avast folder.   Even though both files were modified at the same time, the system folder got the old file!


Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1886
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #35 on: December 24, 2013, 04:11:21 PM »
Thanks a lot, this is a problem. We'll try ti find out why is this happening!





Could you please post a version info of the aswstm.sys file inside c:\Windows\system32\drivers? Just to be sure the fix had been correctly applied.

Ahhh.  In the system folder it's 9.0.2011.263 not the .265 that's in the Avast folder.   Even though both files were modified at the same time, the system folder got the old file!

stephenavast

  • Guest
Re: Fix for WebShield download issues
« Reply #36 on: December 28, 2013, 05:12:11 PM »
I've just 'upgraded' my partners laptop (running windows 7) with Avast 2014.9.,0 2011. Worked 100% before, but now won't connect properly using various browsers to the internet. I either get nothing ( just a 'connection' error), or page doesn't load properly.

I've now disabled 'web shield' and all working again. Is it my understanding that you will automatically apply a long term fix for this via 'automatic updates' rather than me just disabling a major part of the program?


Szilu

  • Guest
Re: Fix for WebShield download issues
« Reply #37 on: December 28, 2013, 07:13:57 PM »
Hello people!

Question and suggestions:
Since the avast 2014 is clearly rushed to the marked could someone make a tutorial or a link to revert to the older version of AVAST?
My browsing experience is a nightmare since i switched to the new version. And in the meantime i would suggest to not push out 2014 update automatically because you will loose a lot of people.

Recommending avast 2014 in this current version is not an option. Not a good thing for holidays.

Thanks!

Offline calcu007

  • Avast Evangelist
  • Poster
  • ***
  • Posts: 482
  • I'm lamma!
Re: Fix for WebShield download issues
« Reply #38 on: December 28, 2013, 08:48:57 PM »
The patch installed without problems in my PC. Win 8.1 64 bit
Asus Intel i7 8GB RAM , Win 8.1 64 bit, Avast IS

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1886
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #39 on: December 28, 2013, 08:54:17 PM »
Thanks for this interresting story. How are your experiences with this patch?

Hello people!

Question and suggestions:
Since the avast 2014 is clearly rushed to the marked could someone make a tutorial or a link to revert to the older version of AVAST?
My browsing experience is a nightmare since i switched to the new version. And in the meantime i would suggest to not push out 2014 update automatically because you will loose a lot of people.

Recommending avast 2014 in this current version is not an option. Not a good thing for holidays.

Thanks!

Szilu

  • Guest
Re: Fix for WebShield download issues
« Reply #40 on: December 28, 2013, 09:48:25 PM »
Well i've tried "waiting for the patch" gave 3 tries around 5-8 minutes of waiting and nothing happened.
The file ends still with 2011.263

This is my system description:
http://i231.photobucket.com/albums/ee111/szilu2002/sysinfo.png
http://i231.photobucket.com/albums/ee111/szilu2002/AvastVersionInfo.png
It's WP7 without SP1 up to date
No firewall besides Windows Firewall

Is there a possibility to run this update via a manual patch? A bat file of sort? As i've seen all older version for avast from "safe" sites have been withdrawn. Or i am missing something? I know it's a standard issue developer 101 but eh...

I just recently got the pro version, i've been using the free one so far.

lord ami

  • Guest
Re: Fix for WebShield download issues
« Reply #41 on: December 28, 2013, 10:01:13 PM »
Well i've tried "waiting for the patch" gave 3 tries around 5-8 minutes of waiting and nothing happened.
The file ends still with 2011.263

This is my system description:
http://i231.photobucket.com/albums/ee111/szilu2002/sysinfo.png
http://i231.photobucket.com/albums/ee111/szilu2002/AvastVersionInfo.png
It's WP7 without SP1 up to date
No firewall besides Windows Firewall

Is there a possibility to run this update via a manual patch? A bat file of sort? As i've seen all older version for avast from "safe" sites have been withdrawn. Or i am missing something? I know it's a standard issue developer 101 but eh...

I just recently got the pro version, i've been using the free one so far.

Check first post on how to manually update and apply the patch :)

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1886
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #42 on: December 28, 2013, 10:08:55 PM »

Is there a possibility to run this update via a manual patch? A bat file of sort?


You can run this from an elevated (Administrator) command prompt:


schtasks /RUN /TN "avast! Emergency Update"

Szilu

  • Guest
Re: Fix for WebShield download issues
« Reply #43 on: December 28, 2013, 10:26:21 PM »
Console:
"C:\Windows\system32>schtasks /RUN /TN "avast! Emergency Update"
SUCCESS: Attempted to run the scheduled task "avast! Emergency Update""

Thank you very much for the help :) it seems my computer refuses the update.

I'll wait around for a few days and will see what happens. No change yet neither in system32 nor the path mentioned in the first post.

If you need some more info, and if it is a priority i'll look into the thread tomorrow.

peterNL

  • Guest
Re: Fix for WebShield download issues
« Reply #44 on: December 30, 2013, 04:57:04 AM »
Hi everybody, especially avast staff members.

I'm writing this with disabled avast cause when it's on I practically can not use internet.
My subscription ends within 10 days and I was just about to renew it like I always do when I saw that avast wants to do an update
- new program version available. I did it .... and the effects of it are visible, no doubt about it, clearly visible in a very negative way.   
I'm using avast for more than 13 years and there were some small issues in these years as it happened with any other av program as well ,
but this, THIS is NO SMALL issue anymore. 
Web browsing slowed down to zero, pages loading forever, sites not being able to open...
On Firefox & on Chrome , the same. When I disable avast and start internet again then everything is top as it used to be, sites & pages load within couple of seconds.
I switch avast back on and the same mess begins.

I DID everything what Lukas wrote in the 1st post of this subject , I also ran it from command prompt as Adm  and still not a single improvement.
aswstm.sys - 9.0.2011.265
aswstm.sys.sum - 233 bytes
However aswstm.sys  is indeed in Win\Sys32\Drivers folder , it is not in SysWOW64\Drivers folder. Is it correct ??

I googeld what oter ppl wrote in this subject and gave it a try, though didn't expect much :

Web Shield off - no result ( after reboot it would I guess, but then what's the point ? )

Enable Web scanning unchecked - no result
Intelligent script scanning unchecked - no result
Script scanning unchecked - no result
All unchecked - no result
 
Seems like modifying WebShield.ini could be the only solution for me right now. I see here that it DID work for some users.
Tell me which lines can I modify, please   
 
WebShield.ini  on my pc :
 
 [Common]
ProviderEnabled=1
[WebScanner]
HttpRedirectPort=80,8080,8091,8081,8008,8888,3124,3127,3128
HttpRedirectPortUpdated1=1
ExcludedTypesList=image/gif;audio/*;video/*
WebScanning=1
WarnFileRep=0
ScanOnlyBrowsers=0
IntelligentStreamScanning=1
DoNotScanTrustedSites=1
NetworkShield=1
ScriptScaning=1
 

I hope this Web Shield issue can be fixed in couple of days... if not then I'll be forced to switch to the other av program and I honestly don't want to do that
cause as I wrote above - I'm an avast user/customer since the end of the 90's and I was ALWAYS very Satisfied with Your excellent av ( till the last update )
 
Thanks god I'm free untill january the 2nd ( Holiday vacations ) other way I couldn't spend so much time tryin' to fix this problem.
 
Forgive me for this very looong post - but in my defence - I have NEVER bother You with any questions in the past 14 years,
if there were some small issues I could always find a solution on the web and fix it by myself. This time it's different. I won't manage it alone. 
 
Please help
Many thanks in advance,
 
Peter Jankowy from Holland
 
 Win 7 64x  no SP1 but I update windows frequently & choose the updates I want. Programs which require SP1  -They all do install on my PC w/out any problem.