Author Topic: Avast is killing Upload speeds  (Read 2522 times)

0 Members and 1 Guest are viewing this topic.

Offline Will U Rage

  • Newbie
  • *
  • Posts: 5
Avast is killing Upload speeds
« on: July 17, 2014, 09:52:49 AM »
Ive been using and promoting/installing Avast for many many years now, and up until tonight I never had an issue with it.

I'm on windows Vista, and my upload speeds have been awful on this PC but somehow my wireless connection to my phone has normal upload speeds.

After TCP tweaks, advanced adapter setting changes and rebooting my modem, I finally found out by using a netstat -b activity.txt command that avast was using my connection. I decided to turn off avast and run the speedtests... and wouldn't you know, they are back to normal.

I updated to the latest version 2021, and re-ran the tests with no luck.

A bit of research shows "web shield" was an issue in version 2012 and supposedly fixed in 2013.

First image shows my speeds with avast running, and second without.... I'd love to continue using avast, but this may be a deal breaker.




Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5202
Re: Avast is killing Upload speeds
« Reply #1 on: July 17, 2014, 10:26:34 AM »
I run Vista with v.2021 with no problems.  What browser are you using and do you keep a lot of tabs open or other applications?  How much memory do you have on your machine?  What other security software (resident) do you have on this machine?
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline Will U Rage

  • Newbie
  • *
  • Posts: 5
Re: Avast is killing Upload speeds
« Reply #2 on: July 17, 2014, 11:42:17 AM »
Hello, I'm using firefox with only 1 tab open, and no other apps running other then avast. 4gb of ram. Windows defender is only other security software (but isn't running) and  Also no other devices active on the network.

Before you say you have no issues, do you mind running a upload test at http://testmy.net/ with and without avast running? You may be surprised.

Offline Will U Rage

  • Newbie
  • *
  • Posts: 5
Re: Avast is killing Upload speeds
« Reply #3 on: July 21, 2014, 07:40:52 AM »
Does anyone from avast read these forums?


Offline Will U Rage

  • Newbie
  • *
  • Posts: 5
Re: Avast is killing Upload speeds
« Reply #4 on: July 22, 2014, 07:54:54 AM »
Could someone else confirm this?

Test upload speed at http://testmy.net with avast running, then test again with avast off.

I'm still having this issue :(

Offline Will U Rage

  • Newbie
  • *
  • Posts: 5
Re: Avast is killing Upload speeds
« Reply #5 on: August 01, 2014, 07:39:50 PM »
Looks as if I can't get any help here.... was patient and checked back, but today i moved on.

I am no longer using or promoting Avast.

I urge everyone to run a speedtest that's not flash or java such as testmy.net and move on to better AV software that doesnt cripple your connection.

Offline NoelC

  • Poster
  • *
  • Posts: 569
Re: Avast is killing Upload speeds
« Reply #6 on: August 01, 2014, 09:42:20 PM »
Thank you for the heads-up.  However, I just tested my connection with the site you suggested.  It's not doing what you say for me.

-Noel



Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5202
Re: Avast is killing Upload speeds
« Reply #7 on: August 01, 2014, 11:00:20 PM »
For me (speed), it depends on my ISP and traffic.  Some days I can't even get online!  I'm sorry I could not respond until now, but I usually have to go online during off-peak hours because of this issue (my ISP)...not Avast.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.