Author Topic: Avast 2015.2.2014 not working with Sandboxie  (Read 11714 times)

0 Members and 1 Guest are viewing this topic.

Offline jwa

  • Full Member
  • ***
  • Posts: 144
  • I'm a llama!
Avast 2015.2.2014 not working with Sandboxie
« on: March 03, 2015, 04:59:28 PM »
I posted in the sticky for the new version, but dodn't know if everyone checks there, so I'll post here also.

Neither of my browsers, Opera nor Firefox, work with Sandboxie after I updated this morning to the lasted version of Avast 2015.2
.2014.

They are ok if not sandboxed.

Can anyone verify if they are also having any problems?

I get pop ups stating the the site is blocked because the certificate is invalid etc

Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3624
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #1 on: March 03, 2015, 05:05:23 PM »
Yes, I can confirm this !

I only use Sandboxie with the Tor browser, so I didn't test it with other browsers which I use the Avast! Sandbox for.
But there is a problem with Sandboxie and Firefox. Disabling HTTPS scanning in the Webshield "solves" it for now.

Thank you for reporting.

Greetz, Red.
OS: Win 7 x64 SP1 / Ubuntu / Qubes OS / iOS
Real Time: Avast Premier Beta + AMS for iOS Beta WinPatrol Plus Unchecky MCShield  HOSTS File: MVPS + MDL
On Demand: MBAM SUMo
Backup: Win 7 Image
Proxy: ASL VPN's Socks 5 Tor

Offline Endt

  • Avast team
  • Full Member
  • *
  • Posts: 140
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #2 on: March 03, 2015, 06:05:19 PM »
Exactly as Rednose said. We are working on this issue, but for now disable the HTTPS scaning.

Thanks

Offline jwa

  • Full Member
  • ***
  • Posts: 144
  • I'm a llama!
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #3 on: March 03, 2015, 10:24:57 PM »
What would the security hit be for disabling HTTPS?

Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3624
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #4 on: March 04, 2015, 02:13:57 PM »
What would the security hit be for disabling HTTPS?

That the Webshield doesn't scan HTTPS ( encrypted ) connections. All HTTP ( non encrypted ) connections will be scanned though.
As you still have the Realtime shield, and a Sandbox you run your browser in, the security risk is an absolute minimum imo.

Greetz, Red.
« Last Edit: March 05, 2015, 02:37:08 AM by Rednose »
OS: Win 7 x64 SP1 / Ubuntu / Qubes OS / iOS
Real Time: Avast Premier Beta + AMS for iOS Beta WinPatrol Plus Unchecky MCShield  HOSTS File: MVPS + MDL
On Demand: MBAM SUMo
Backup: Win 7 Image
Proxy: ASL VPN's Socks 5 Tor

Offline haggisfarmer2

  • Newbie
  • *
  • Posts: 16
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #5 on: March 04, 2015, 10:57:12 PM »
Having the same problem here....started after installing latest version of Avast!

Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3624
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #6 on: March 04, 2015, 11:11:00 PM »
Hi haggisfarmer2, welcome to the forum :)

Yes, it is a bug that Avast is working on. All you can do for now is disable HTTPS scanning.

Greetz, Red.
OS: Win 7 x64 SP1 / Ubuntu / Qubes OS / iOS
Real Time: Avast Premier Beta + AMS for iOS Beta WinPatrol Plus Unchecky MCShield  HOSTS File: MVPS + MDL
On Demand: MBAM SUMo
Backup: Win 7 Image
Proxy: ASL VPN's Socks 5 Tor

Offline haggisfarmer2

  • Newbie
  • *
  • Posts: 16
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #7 on: March 04, 2015, 11:17:13 PM »
Thank you Rednose


Offline -Genesis-

  • Sr. Member
  • ****
  • Posts: 284
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #8 on: March 05, 2015, 08:49:39 AM »
Im having the same problem
Windows 10 Pro 1703/ Windows Defender/ Sandboxie/
Ryzen 5 1600/ Aorus Gtx 1080Ti Xtreme/ Gskill Trident Z RGB 3000/ Samsung Evo 250GB/ Western Digital Black 1 TB

Offline -Genesis-

  • Sr. Member
  • ****
  • Posts: 284
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #9 on: March 05, 2015, 08:57:43 AM »
Hi Avast fans,

I'm glad to announce a new version of Avast Antivirus for Windows (Free, Pro, Internet Security, Premier).
Version number: 2015.10.2.2214

What's new:

- Improved Windows 10 Compatibility

- Browser Cleanup integrated to Avast UI and added to Smart Scan

- WebShield improvements for faster browsing and fixed issues with expired certificates

- Avast NG virtualization – performance and stability fixes

- AccessAnywhere feature is removed and replaced with remote connection feature available through Account screen in all editions(not limited to Premier)

- New design of Chrome plugin

- Better license activation during setup

Download links:
Online installers
http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

Full installers
http://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_internet_security_setup.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup.exe

It's recommended to use the in-product update (Settings->Update->Program), if you have Avast already installed.

Enjoy this version, it's much better than the previous ;-)

Martin

Funny as they say that it  fixed issues with expired certificates. Well im getting infinite expired certificates using sandboxie!
Windows 10 Pro 1703/ Windows Defender/ Sandboxie/
Ryzen 5 1600/ Aorus Gtx 1080Ti Xtreme/ Gskill Trident Z RGB 3000/ Samsung Evo 250GB/ Western Digital Black 1 TB

Offline DanielDuesentrieb

  • Newbie
  • *
  • Posts: 2
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #10 on: March 06, 2015, 12:11:02 PM »
Same problem with more details:
Outside the sandbox I can access all web pages, especially *.google.com, *.yahoo.com, *bing.com
  Inside the sandbox my Browsers say: Page not found for *.google.com  and www.yahoo.com
Avast message pops up = Avast web shield has blocked access because the following certificate is unvalid:
*.google.com  and www.yahoo.com
Inside the sandbox *bing.com is found, no problem

Tested with both, Firefox36.0.1 and Internet Explorer 11.
Latest versions of Sandboxie-4.16(64bit) and Avast-free-2015.10.2.2214 under Windows7-64.
Remove and Clean install of both Sandboxie and Avast does not help.

No problem with older version of Avast, Avast-free-2015.10.0.2208 (and same Sandboxie-4.16(64bit), same firefox).
Has anyone tested to reinstall OLD VERSION 2015.10.0.2208?

Offline -Genesis-

  • Sr. Member
  • ****
  • Posts: 284
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #11 on: March 07, 2015, 04:14:37 AM »
only the latest version of avast has the problem. ive tested it.
Windows 10 Pro 1703/ Windows Defender/ Sandboxie/
Ryzen 5 1600/ Aorus Gtx 1080Ti Xtreme/ Gskill Trident Z RGB 3000/ Samsung Evo 250GB/ Western Digital Black 1 TB

Offline haggisfarmer2

  • Newbie
  • *
  • Posts: 16
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #12 on: March 07, 2015, 11:34:37 AM »
Is there any update on when this might get fixed?

Thanks

Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3624
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #13 on: March 07, 2015, 11:46:29 AM »
Is there any update on when this might get fixed?

Thanks

Not that I know, but I will try to find out.
But it is weekend, so be patient :)

Greetz, Red.
OS: Win 7 x64 SP1 / Ubuntu / Qubes OS / iOS
Real Time: Avast Premier Beta + AMS for iOS Beta WinPatrol Plus Unchecky MCShield  HOSTS File: MVPS + MDL
On Demand: MBAM SUMo
Backup: Win 7 Image
Proxy: ASL VPN's Socks 5 Tor

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5410
  • Spartan Warrior
Re: Avast 2015.2.2014 not working with Sandboxie
« Reply #14 on: March 09, 2015, 06:15:11 AM »
Is there any update on when this might get fixed?

Thanks

Not that I know, but I will try to find out.
But it is weekend, so be patient :)

Greetz, Red.
Rolled back to 2015.10.0.2208 AIS after experiencing the same issues above, used System Restore to do that.  Also noted that the avast! sandbox also has issues with certificate validation as the browser window for Firefox 36.0 is very slow to open and then hangs with a black window; then FF will proceed to load without certificate blocks.  Otherwise, certificate blocks will be announced with Sandboxie 4.16 and either IE 11 or Firefox and no internet access is possible.  I've seen as many as 14 blocks on one website alone when running Sandboxie.

Updated via GUI to see what would happen, just so you know.

Running Win 7 SP1 64-bit, now 2015.10.0.2208 AIS installed.  Internet is accessible with .2208 with both sandboxes but not with .2214, one does not work, and noticeable hangs with avast! Sandbox, also with version .2214, for both IE 11 and FF 36.0.1.

So the .2214 version ssl certificate validation issue appears to also affect AIS Sandbox to some degree.

Did check for operation running both browsers normally (no sandbox) and did not see any problems running .2214.

Interestingly, using System Restore also caused an issue with an avast! failed start on reboot, even though a step was taken to untick the box for the self-defense module in Troubleshooting before running the first System Restore on avast! install.  Here, self-defense was unticked prior to running the GUI web update.

Workaround for that was to go to Troubleshooting, check to see if self-defense was enabled on reboot.  It was.  Unticked that box, and clicked "Fix All" and all was fixed without doing an avast repair.  So, restoring to .2208 caused an unexpected issue.

Can't run .2214 as things stand now, as proper ssl certificate validation is crucial to privacy and user security.

[EDIT:] Corrections made to avast! versions, changed from .2008 to .2208, and .2014 to .2214.
« Last Edit: March 09, 2015, 06:56:05 AM by mchain »
Windows 10 Home 64-bit 1809 Avast Premier Security version 19.8.2393 (build 19.8.4793.541) UI version 1.0.415.  Current version is back to Avast Internet Security.