Author Topic: [Solved] Avast internet connection issues  (Read 30291 times)

0 Members and 1 Guest are viewing this topic.

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
[Solved] Avast internet connection issues
« on: May 09, 2015, 08:09:48 AM »
Hello,

since my avast installation on clean windows 7 2 days ago I'm experiencing one issue after another. I already made package yesterday and sent it but still no reply - ID: JEQHY

For some reason Avast think my computer is offline and not connected to the internet. I tried to repair the installation and run diagnostic tool but nothing was detected. Now I'm getting these kind of messages (It seems that you are offline. Internet connection is needed to perform network security scan. Please, check your internet connection and try again) when I try to register, login into my account, access the Shop page or run some home network tests. It has been like that since the day I installed avast and I really don't know what to do and how to make avast work. I tried to restart my modem and internet connection on computer but I'm not experiencing any issue with internet except with avast that just won't connect to the internet no matter what.
« Last Edit: May 10, 2015, 10:01:57 PM by Haseo »

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 70578
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast internet connection issues
« Reply #1 on: May 09, 2015, 08:13:25 AM »
Sounds like AvastUI.exe is blocked, allow it in your firewall.
Win 8.1 [x64] - Avast PremSec 21.5.6346.B5i [UI.645] - EEK - Firefox ESR 78.11 [NS/uBO/PB] - TB 78.11
Avast-Tools: Secure Browser 91.0 - Cleanup 21.1 - SecureLine 5.12 - Driver Updater 21.1 - CCleaner 5.81
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #2 on: May 09, 2015, 08:49:58 AM »
Sounds like AvastUI.exe is blocked, allow it in your firewall.
That didn't help. Tried to add an exception to my windows firewall for avast and even turn off firewall for a while but still can't connect to my account or register my avast installation. Also I have not seen any avast pop-up window since this installation 2 days ago but when I checked my avast version it looked like it's up to date. And AvastUI is running in my task manager together with AvastSvc.exe. Also I noticed that my avast is installed in 64 bit program files folder but those AvastUI and AvastSvc both have *32 bit version at the end. Never noticed this before and I'm not sure if it's okay.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 70578
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast internet connection issues
« Reply #3 on: May 09, 2015, 09:40:55 AM »
- Which Avast..? (Free/Pro/IS/Premier)
- Which version..?
- OS..? (32/64 Bit..? - which SP..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
Win 8.1 [x64] - Avast PremSec 21.5.6346.B5i [UI.645] - EEK - Firefox ESR 78.11 [NS/uBO/PB] - TB 78.11
Avast-Tools: Secure Browser 91.0 - Cleanup 21.1 - SecureLine 5.12 - Driver Updater 21.1 - CCleaner 5.81
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #4 on: May 09, 2015, 11:00:11 AM »
- Which Avast..? (Free/Pro/IS/Premier)
- Which version..?
- OS..? (32/64 Bit..? - which SP..?)
- Other security related software installed..?
- Which AV(s) did you use before Avast..?
- avast free antivirus 2015
- program version 2015.10.2.2218, virus database version 150508-1
- windows 7 ultimate 64-bit, service pack 1
- no other security related software
- I have been using only avast for past 8 years or so. Also it's completely clean new windows installation that I did 2 days ago (complete HDD format and new installation). Avast was one of the first applications I installed after windows/SP/drivers installation and those issues started from the moment I installed avast. I used that online installer which I downloaded from the official site and once I opened the installer it took really long time (maybe 10 minutes) before all files were extracted and installation started which was the first strange thing I encountered. Once the installation process started it was quick and everything went smoothly.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 70578
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast internet connection issues
« Reply #5 on: May 09, 2015, 11:02:31 AM »
1. Download Avast Free Antivirus: https://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
2. Follow instructions: https://www.avast.com/uninstall-utility (Run this tool for all prior installed Avast versions..!!)
3. Reinstall Avast with the downloaded installer from point 1.
4. Reboot.
Win 8.1 [x64] - Avast PremSec 21.5.6346.B5i [UI.645] - EEK - Firefox ESR 78.11 [NS/uBO/PB] - TB 78.11
Avast-Tools: Secure Browser 91.0 - Cleanup 21.1 - SecureLine 5.12 - Driver Updater 21.1 - CCleaner 5.81
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #6 on: May 09, 2015, 11:27:33 AM »
Thanks, gonna try that.

By the way, I opened that avast uninstall utility and I had to wait for 10 minutes already before I could proceed with uninstallation. Exactly the same issue I had when I tried to install avast with online installer. I could see only avast logo and some loading circle. Is that normal that it takes so much time to start uninstallation/installation process ?

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #7 on: May 09, 2015, 12:06:39 PM »
Ok so I did as instructed above and reinstalled avast but the issues remains. Still can't register or log into my avast account, scan network or open shop page and avast still slows down my computer so I have to turn off shields. Everything works just fine without avast or with avast turned off. I forgot to mention that I installed only avast shields, not any of those tools in the middle column but that shouldn't be an issue since they are not required to run avast and I don't need them, never used them before anyway and it was working just fine until this week. There clearly is something wrong with avast, be it some compatibility issues or just broken update that started these issues.

Since a clean windows installation with only service pack, drivers and avast does not work then I don't know what else to try.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Avast internet connection issues
« Reply #8 on: May 09, 2015, 12:19:40 PM »
What firewall do you have ? Do you use windows7firewall control

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #9 on: May 09, 2015, 12:57:39 PM »
What firewall do you have ? Do you use windows7firewall control
I have default windows 7 firewall. I didn't change anything there, it's using default settings. I opened it for the first time today when Asyn recommended me to allow avast there. I added avast into exceptions in firewall which didn't help. I also tried to turn it off but that also didn't help.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Avast internet connection issues
« Reply #10 on: May 09, 2015, 01:21:44 PM »
The problem you are getting is usually when a firewall blocks access to the internet for Avastsvc

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #11 on: May 09, 2015, 03:53:14 PM »
Thanks for all your tips and ideas about where the problem might be but I'm still stuck without any working solution and I did everything that was suggested to me, also provided as much information as posible.

I tried few other things. Firstly I turned my firewall off, rebooted and tried to register my avast installation but no success. Then I restored firewall settings to default, still nothing. Allowed avast in firewall exceptions manually, still nothing. Then I decided to install avast on my laptop which did not have any antivirus installed and I'm experiencing exactly same issues as on this main computer. This computer is connected to my modem by cable while laptop is using wifi. There is no way that the problem is with my computer. Main PC is running win 7 ultimate 64bit, laptot is running win 7 ultimate 32bit and I did complete installation of avast with all tools included on laptot and custom installation with only shields on main PC jus to see if the problem is not some missing tool that I did not include in the installation.

There are 2 things that I can think of as being the problem. One is something is terribly wrong with avast program since few days ago. Other one is that there is something wrong with my internet connection (not sure if its provider or modem) but I'm not experiencing any other internet problems. I'm downloading, online gaming, streaming and browsing the internet just fine, only avast is having some issues. Not to mention that both installations on each PC took several minutes just waiting for that avast_self_extract process to start the installation. Installation was very quick but the wait before I can start the installation is ridiculously long on both PCs. Not sure what avast does in that time since it takes only few seconds for it to create some temp folder in documents and after that the process just hangs and nothing is happening, after several minutes the installation window appears.

Any help appreciated, I'm getting very frustrated with this issue, really. I already sent a package and posted in a diferent topic about how avast slows down file handling which also happens to be problem for both of my pcs and also for other users as seen in that topic and I still did not get any new info.
« Last Edit: May 09, 2015, 03:54:50 PM by Haseo »

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Avast internet connection issues
« Reply #12 on: May 09, 2015, 04:14:49 PM »
Are you using the standalone installer or the web installer ?

Reading from the problems you are experiencing I would hazard a guess at a programme conflict somewhere.  I am running Avast on XP, 7, 8 and TP10 with no problems

Offline Haseo

  • Jr. Member
  • **
  • Posts: 25
Re: Avast internet connection issues
« Reply #13 on: May 09, 2015, 06:30:26 PM »
On my main PC I installed avast using this installer - https://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
On my laptop I used that 5mb installer (probably what you mean by web installer). Same issues no matter which I used.

Also I noticed something while looking at event viewer and found these registry handles leakes. Not sure if it's related to my issues. According to times they always appear in my even viewer when I restart or shut down my pc. All are EvenID 1530. Not sure what to do about it.
« Last Edit: May 11, 2015, 11:09:18 AM by Haseo »

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Avast internet connection issues
« Reply #14 on: May 09, 2015, 06:43:32 PM »
Is Avast installed on the C or D drive as the log appears to indicate it is on the second partition