Author Topic: Avast blocking most internet traffic when Web Shield is enabled  (Read 19184 times)

0 Members and 1 Guest are viewing this topic.

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84910
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #45 on: July 27, 2015, 04:24:09 PM »
Well it isn't a fix but a work around, which was suggested to save going back to an earlier version that has the same impact in XP and Vista, they can't scan HTTPS pages. Not to mention you would lose out on any other benefits that were included and working in 10.3.2223.

The weird thing is that it isn't consistent across all XP systems (mine is fine), which can only make it harder to pin down the exact cause.

EDIT: It seems this may have been pinned down as in another post they believe it is for those still using XP SP2 - my guess it seems that the mod to be able to scan HTTPS doesn't work in XP SP2 - we will have to wait and see. But what it means those still using XP SP2 won't have the HTTPS scanning function or those with SP2 will have to get SP3. Not sure how that would work with XP Pro SP2 64bit as there is no SP3 for that OS version.

See: https://forum.avast.com/index.php?topic=174079.msg1237172#msg1237172, last paragraph.
« Last Edit: July 27, 2015, 04:34:48 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline skinnypops

  • Full Member
  • ***
  • Posts: 106
  • backup, backup, backup
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #46 on: July 27, 2015, 06:56:08 PM »
hi all,

just to note. https scanning all fine here on win vista home premium.

skinnypops

new HP , amd a10-8700p quad core @ 1.8 gig radeon r6 graphics ,dedicated radeon r8 2gb graphics card, 8 gig ddr3-1600 memory, 1 tb hdd, win 10x64 home 1607 build 14393.1066, avast free 17.3.2291,  windows firewall, mbae free, mbam free, open dns, cryptoprevent, mcshield, paragon bu & recovery 2015,system explorer

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84910
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #47 on: July 27, 2015, 08:05:57 PM »
hi all,

just to note. https scanning all fine here on win vista home premium.

skinnypops

This has been an intermittent issue with not all XP and Vista users effected, but some certainly are, all of which makes it harder to find and fix the fault.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline MartinZ

  • Moderator
  • Advanced Poster
  • *
  • Posts: 1070
  • Product Manager
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #48 on: July 28, 2015, 02:39:48 PM »
Hi,

the hotfix is live now, so users who have version 2223 and problems with browsing should just restart computer.
Users who will update to 2223 now will already have the fix applied and HTTPS scanning will be disabled for them by default.
(applies only for XP SP2)

Offline Dhaken

  • Newbie
  • *
  • Posts: 7
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #49 on: July 29, 2015, 12:06:48 AM »
This is a still a problem with Windows 8.1.

We are now using free version .2225 , early versions also blocked traffic (2 weeks or so). But only on my children's (3) PCs are blocked ( they are running windows Family Safety ). My computer, not running the Family Safety, has worked well throughout these last few avast program updates.

If I turn off the Https scanning , as suggested in the post regarding xp issues, their PCs can once again connect to the sites (namely youtube.com).

Thanks for any updates in this regard. I hope this post isn't buried in this thread.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45276
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #50 on: July 29, 2015, 03:11:24 AM »
This is a still a problem with Windows 8.1.

We are now using free version .2225 , early versions also blocked traffic (2 weeks or so). But only on my children's (3) PCs are blocked ( they are running windows Family Safety ). My computer, not running the Family Safety, has worked well throughout these last few avast program updates.

If I turn off the Https scanning , as suggested in the post regarding xp issues, their PCs can once again connect to the sites (namely youtube.com).

Thanks for any updates in this regard. I hope this post isn't buried in this thread.

Strange, I run Windows 8.1 and the latest version of Avast free. I have no problem accessing Youtube. I view videos, upload and download video's without problems.
Is Avast allowed access through your firewall ???
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline Dhaken

  • Newbie
  • *
  • Posts: 7
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #51 on: July 29, 2015, 04:28:11 AM »
I don't have trouble either, but the kid's PCs do. The only difference is that they are protected from inappropriate sites by windows "Family Protection" settings. Once the https shield is turned off on avast they can once again have access to the sites that I have unblocked.
« Last Edit: July 29, 2015, 04:37:04 AM by Dhaken »

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45276
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #52 on: July 29, 2015, 08:04:27 AM »
I don't have trouble either, but the kid's PCs do. The only difference is that they are protected from inappropriate sites by windows "Family Protection" settings. Once the https shield is turned off on avast they can once again have access to the sites that I have unblocked.
What O[erating System does that computer run ???
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline mariusz30

  • Newbie
  • *
  • Posts: 2
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #53 on: July 29, 2015, 12:12:31 PM »
Hi Guys.

I've found that last update turn off scan of SSL connections in mail shield settings too (on
my computer with XP SP2).

In my case, it caused the problem with e-mail send and receive inside TheBat mail program (my mailbox is set to TLS connection).

Everything work fine after I "checked back" SLL connection option.

Maybe this option shouldn't be automatically unchecked by the update ?
Computer work fine if only HTTPS scan is turn off.

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84910
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #54 on: July 29, 2015, 02:50:03 PM »
@    mariusz30
Read Reply #20 and Reply #48 by MartinZ avast team member.

Ideally you should update your XP SP2 to SP3, that way HTTPS scanning won't be disabled.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline mariusz30

  • Newbie
  • *
  • Posts: 2
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #55 on: July 29, 2015, 03:26:14 PM »
I've already HTTPS scan disabled. Scan of SSL connection is a different thing (in mail shield setting). I mean when you made update which turn off HTTPS scan in XP SP2, scan of e-mail SLL connections was also disabled.

Just indicate that others which use XP SP2 and e-mail programs can have problem with e-mail send/receive after last update. They must turn back on SSL scan for mail shield, but keep HTTPS scan disabled for the websites and everything will be fine.

« Last Edit: July 29, 2015, 03:28:24 PM by mariusz30 »

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84910
  • No support PMs thanks
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #56 on: July 29, 2015, 03:44:56 PM »
I've already HTTPS scan disabled. Scan of SSL connection is a different thing (in mail shield setting). I mean when you made update which turn off HTTPS scan in XP SP2, scan of e-mail SLL connections was also disabled.

Just indicate that others which use XP SP2 and e-mail programs can have problem with e-mail send/receive after last update. They must turn back on SSL scan for mail shield, but keep HTTPS scan disabled for the websites and everything will be fine.

There is no need to disable HTTPS as the latest avast version 10.3.2225 will detect that you have XP SP2 and disable that functionality. Even if you stuck with 2223 there was a hotfix (probably delivered during a VPS and engine update to disable that function in XP SP2.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Troika

  • Newbie
  • *
  • Posts: 3
Re: Avast blocking most internet traffic when Web Shield is enabled
« Reply #57 on: July 30, 2015, 04:54:39 PM »
Ref: Avast blocking most internet traffic when Web Shield is enabled - well it's worse than this with my XP PC.

I've been using Avast successfully for many years. Normally it's excellent! But I installed vers. 10.3.2225 yesterday and it has corrupted my old XP workhorse. The symptoms are: (1) Avast states some shields are inactive; (2) the webshield is inactive but cannot be acivated as setting it ON is ignored; (3) eventually (and usually when starting a browser - say chrome) the PC hard stops (mouse & keyboard don't work) leaving only power off as a procedure.

I have no ideas of a workaround for this except removing Avast clears this bug (as proven three times).

I am having no trouble with my Windows 7 PC and this version of AVAST.

Just to confirm that I too, amongst the many it seems, have to keep XP running for legacy systems that do not work correctly in Windows 7.  Whether they work in W8/8.1 or 10 is immaterial. So I hope Avast will find a solution and continue to support us XP users into the future.