Author Topic: Avast free antivirus behind proxy - manual update works - automatic update fails  (Read 4545 times)

0 Members and 1 Guest are viewing this topic.

Offline mailvj

  • Newbie
  • *
  • Posts: 2
Dear All,

I see some strange behaviour of avast free antivirus 2015 and 2016.
There is a non transparent squid proxy server in my LAN.
My PCs (win7, win8, no desktop firewall) are well configured to use is for browsing etc (automatic detection via wpad)

As I saw no "automatic proxy feature" to configure in my avast installation, I configured the proxy settings manually.
My MANUAL updates work fine.

But AUTOMATIC updates do not work, after several days I still see the version I updated manually.
When I click "update manally", I get updates to the latest version.

I analyzed this automatic update behaviour on two of my PCs with wireshark.
This is what I saw:
- dns queries and answers for avast domain names
- tcp syn packets directly to Avast Internet IPs
- NO packets to my proxy server.

So obviously the avast automatic update directly tries to connect to the update servers , ignoring the proxy settings.
I saw the same behaviour with the register feature in the avast GUI --> no connecton possible.

So I would like to ask you two questions:

1) is there anyone using avast free antivirus 2015/2016 behind a proxy without the problems i described?
2) does anyone of you have an idea how to solve or workaround the behaviour I saw?


Thanks a lot!
Sepp

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31305
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Setting up the proxy details correctly in avast should work.

Offline mailvj

  • Newbie
  • *
  • Posts: 2
Dear Eddy,
thanks for your reply!

As my manual updates in the GUI work, I guess I inserted the proxy settings in the Avast GUI at the right place in the right way  ;)
By the way: a manual update with the command line tool "ashupd.exe" also works as designed, it utilizes the proxy information perfectly.

The only one ignoring proxy settings seems to be automatic updates :-)

You wrote: "Setting up the proxy details correctly in avast should work."
Have you seen avast free antivirus 2015/2016 working correctly with proxy settings and automatic updates?

Greetings,
Sepp

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31305
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Yes, I have seen it work in/with 2015 lots of times.
I used to have a computer (related) service and installed avast 100's of times, including for people who use a proxy.
I have not seen it working with 2016 simply because I never have installed that version.

I suggest you try it with a other proxy server and see if that is working.
If it is, the problem is with the current proxy server.