Author Topic: Current Issues, Questions, Feedback, Feature Requests  (Read 620 times)

0 Members and 1 Guest are viewing this topic.

Offline TechTrashPanda

  • Newbie
  • *
  • Posts: 3
Current Issues, Questions, Feedback, Feature Requests
« on: October 09, 2019, 06:13:35 AM »
Hey avast team,

I've been using Omni for a while now, and have run in to a few different issues. Some may have simple solutions but others might require a bit more planning and development.

I am using the Omni on a fairly simple network setup, phones, gaming devices, and computers for four adults. The device seemed to work rather flawlessly when it was first installed, but has since been accumulating small errors that are making simple network tasks fail or stall.

For example:
  • My devices no longer seem to see one another. My network behaves similarly to having a router in isolation mode.
    e.g. Neither the Xbox android app nor the Xbox Console Companion on windows will recognize my Xbox. It worked when the device was installed.
  • According to both the LAN and wireless client lists, there are at least double entries for each device, some with an ipv4 address and others with a format I suspected to be ipv6, but does not follow the format. These accrues are also incomplete, with MAC addresses matching other devices, but invalid entries for other sections.
    I suspect this has to do with the was the hub protects your Iot devices, but I believe it interferes with the way devices are communicating.
  • According to several different sections of the windows pc I manage my network with, I am now connected to [my ssid] 2. There is not another entry sharing my ssid's name in the manage known networks list, but inside my registry there are double entries for just this Ssid, having similar missing and empty entries and hex formats as seen on the client lists.i believe this issue is what is causing the communication errors. It's as if my devices cannot sync their clocks and host names even though they all run on the same channel of the same network.


As far as the UI goes, I've mentioned before in the forum: please remove parental control features, downtime, and no-notification location tracking from the adult profiles. It even says in the FAQs for Omni that those features are not supposed to be present on adult family members.the only feature that should remain is location sharing, but it should have to be turned on from the member side for adults.
It would also be nice to have more detailed reporting from the device beyond internet usage. Reports about what behaviors it is monitoring and rules it is implementing. Or at least a ability to download logs on our own side for troubleshooting. Perhaps have an advance user menu section for beta testers?

My first question concerns DHCP mode. It is not addressed anywhere in any material for the Omni in what conditions the mode should be enabled in, although I believe it hands over DHCP handling to the Omni over your router. I had enabled the mode after reconfiguring my hub while trying to remedy my issues, and partway through the setup I hit a snag because my router had logged me out during the router portion of the setup, and said it was logged in elsewhere. I believed this was the intent of the setup, but it seemed to fail. I had to reset everything but we are back to where we were before I attempted to use the mode with no change in my issues.

The avast apps on my friends phones always report as inactive or partially disabled, and they aren't doing it themselves. I am at a bit of a loss about this, unless it relates to battery saving functions.

I thought it would be a good idea to ask if there is any implementation planned for dns over tls or other privacy services. I use cloudflare's 1.1.1.1 dns servers on my devices and router, with a tertiary server on 8.8.8.8 as a failsafe. I also use their encryption and dns services through my device (I have tested all the above with it both on and off) and would like to further implement it in my network. Giving encrypted dns routing capabilities to the Omni would be a great marketing point for you guys and be amazing for users.
For readability:
  • What is DHCP mode in terms of the Omni hub?
  • What network conditions would this apply to?

I have worked with avast for many many years and have been super excited to beta test this with you. I look forward to actively assisting you in troubleshooting and further testing this product if I can.

Offline HeffeD

  • Jr. Member
  • **
  • Posts: 31
Re: Current Issues, Questions, Feedback, Feature Requests
« Reply #1 on: October 10, 2019, 07:11:58 PM »
I am using the Omni on a fairly simple network setup, phones, gaming devices, and computers for four adults. The device seemed to work rather flawlessly when it was first installed, but has since been accumulating small errors that are making simple network tasks fail or stall.

I've had much the same issues with Omni adversely affecting my network. The device is aimed at protecting IoT devices, yet in my experience, it is actually detrimental to the operation of 'smart' devices connected to my home automation server. Constant dropouts, disconnects, unavailability, etc...

I've actually had to abandon the Omni because as near as I can tell, they're not actually interested in beta feedback like this. I first reported my networking issues back in July. No fixes whatsoever. I too was excited about beta testing this device because I feel it has great potential, but the lack of support has left me with a very poor impression of the Avast team.  :-\

I am still more than willing to fire it back up if they're actually interested in improving the product, because as I said, I feel the product has great potential, but as near as I can tell, they consider the beta phase complete.

Offline Zbyněk6

  • Avast team
  • Jr. Member
  • *
  • Posts: 26
Re: Current Issues, Questions, Feedback, Feature Requests
« Reply #2 on: October 15, 2019, 05:34:42 PM »
Hello @TechTrashPanda, I'm verifying answers to your questions with our developers. I'll get back to you once we have an answer from them.

@Heffe.D You've been in touch directly with developers, and many of your issues were reported. I'll also check the status of these issues.

I appreciate your patience. Thank you