Author Topic: Minor but annoying XP startup issue with 4.7.981  (Read 18552 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #15 on: April 16, 2007, 05:51:25 PM »
I see it coming. However, I'd strongly suggest to compress (e.g. ZIP) the file - this usually makes it at least 3x smaller.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83960
  • No support PMs thanks
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #16 on: April 16, 2007, 06:00:31 PM »
@ Crashman
That looks fine, naming the file as you have should help Vlk if there are other .dmp files.

Edit: didn't see Vlk's post on a 2nd page and he has already seen it
« Last Edit: April 16, 2007, 06:02:06 PM by DavidR »
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.8.2432 (build 20.8.5684.602) UI-1.0.566/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #17 on: April 17, 2007, 02:42:15 AM »
Vlk,

Sorry about not compressing the dump file before sending it.  I was so excited that I figured out how to FTP it to you that I just sent it off without thinking. :-[ ;D With some luck, the upload should be finished in a few hours.

I got to thinking about why this boot hang seems to be such an isolated problem.  On April 10, Microsoft issued a number of critical XP patches which changed what I believe are core system files, and which I installed when Windows Update offered them last Tuesday.  For example,
         KB931784 provided new versions of ntkrnlmp.exe, ntkrpamp.exe, ntoskrnl.exe and ntkrnlpa.exe;
         KB930178 issued a new version of winsrv.dll;
         KB925902 installed updated versions of mf3216.dll, gdi32.dll, win32k.sys and user32.dll;
         KB931261 gave us a new upnphost.dll; and
         KB932168 updated xpsp3res.dll and agentdpv.dll
Perhaps something new in one or more of these updated core files caused .981 to hang a bit at boot up when the "group" registry setting is enabled.

I would also add that the HAL.dll that my system is using is actually renamed from halmacpi.dll for my dual-core processor.  This file is version 5.1.2600.2180 and dated 2/28/2006.

Thanks again for your patience with me in this process and for your quick help in tracking down whatever the issue might be.

Regards,
Crashman

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #18 on: April 17, 2007, 12:44:24 PM »
Hi Crashman,

the dump finally arrives. Thanks!

Now, I'd need you to do some more tests. From the command-line (cmd.exe), please try the following commands:

fltmc instances

fltmc volumes

(one at a time) and please post back the output you're getting.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #19 on: April 17, 2007, 02:16:07 PM »
Hi Vlk,

For the first, I get "no filters/instances found" and for the second I get "no volumes found".

Regards,
Crashman

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #20 on: April 17, 2007, 02:45:58 PM »
OK, thanks.

One more question: does WebDAV ring a bell to you? I mean, are you (intentionally) using any WebDAV drives?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #21 on: April 17, 2007, 02:50:17 PM »
Not that I am aware of, although the XP WebClient service does run at startup, and that service claims to be dependent on the WebDav Client Redirector...

Crashman

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #22 on: April 17, 2007, 02:59:29 PM »
And that's exactly where the system was stuck at the moment you captured the dump!

I'd like to ask you to try to disable the Web Client service and restart (with the new version, with the Groups value set). Does that resolve the problem as well?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #23 on: April 17, 2007, 03:12:03 PM »
Vlk,

Disabling the WebClient service reduces the startup sound delay by about half.  A delay still occurs, but its duration is now about 4-5 seconds or so.

Crashman

EDIT:  May I ask you what the "groups" registry setting does?  Despite the fact that it seems to introduce a slight boot delay for Windows XP itself, all my programs seem to load faster with avast! resident and the groups setting in place than when there is no antivirus at all resident in memory!  Firefox loads virtually instantly now, and I've never seen anything close to that before, with or without an antivirus program running. It's pretty remarkable!
« Last Edit: April 17, 2007, 03:29:48 PM by Crashman »

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #24 on: April 17, 2007, 03:44:49 PM »
1. Could you please try running this small app http://public.avast.com/~vlk/WebDavMiniTest.exe and report back what it says?

2. The Group value only causes avast to load much earlier during the boot process. That is, it provides extra protection against malware that starts automatically with the OS. I don't think it can give your machine any "magical" performance boosts though... :)
If at first you don't succeed, then skydiving's not for you.

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #25 on: April 17, 2007, 03:51:58 PM »
Vlk,

1. With WebClient service still disabled, running WebDavMiniTest results in "WsLoadRedir returned 2".

2.  Maybe I'm going insane or something, or a victim of the "placebo effect", but I'd swear that programs load faster!

Thanks!

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #26 on: April 17, 2007, 03:53:29 PM »
Quote
1. With WebClient service still disabled, running WebDavMiniTest results in "WsLoadRedir returned 2".

That is very strange I have to say.
And, I assume, if the Groups value is not there, the result is different? (e.g. "WsLoadRedir returned 0"?)

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #27 on: April 17, 2007, 03:54:54 PM »
BTW isn't there anything suspicious in the Windows Event Log? Something recurring on every boot... (especially in the System category).

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #28 on: April 17, 2007, 04:04:21 PM »
Vlk,

Nothing suspicious in any section of the WIndows Event Log (that is, no warnings of any kind).

Let me remove the groups value again, reboot, and retry the minitest again.

Back in a couple minutes,

Crashman

Offline Crashman

  • Jr. Member
  • **
  • Posts: 62
Re: Minor but annoying XP startup issue with 4.7.981
« Reply #29 on: April 17, 2007, 04:09:55 PM »
Vlk,

With the groups value removed now, the value returned is still 2.

EDIT:  Actually, now that I have tested with and without the groups value, the improved load times of programs seems to be a function of the new version .981, not the groups registry setting.  At least for Firefox and a few other programs I have tried, the load is lightning fast...
« Last Edit: April 17, 2007, 04:21:56 PM by Crashman »