Author Topic: setifaceUpdatePackages() failed  (Read 20488 times)

0 Members and 1 Guest are viewing this topic.

magostoni

  • Guest
setifaceUpdatePackages() failed
« on: January 11, 2008, 12:23:19 PM »
Hi,
I'm new to this forum; we installed Avast server edition on our server and the automatic update work well at the beginning; now since 7 january 2008 we receive all the time the software try an update the error message in the log:

Function setifaceUpdatePackages() has failed. Return code is 0x00000426, dwRes is 00000002.

We receive the error also if we try the manual update.

What does it means?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: setifaceUpdatePackages() failed
« Reply #1 on: January 11, 2008, 12:51:45 PM »
Is this error still present?
Seems just verbose of the logs.
You can search the forum for 0x00000426 keyword.
The best things in life are free.

Forejt

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #2 on: January 14, 2008, 10:33:30 AM »
Check the services control panel, is avast! iAVS4 Control Service running and set to automatic startup?

magostoni

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #3 on: January 14, 2008, 04:14:50 PM »
avast! iAVS4 Control Service is running; I have also restarted it but nothing is changed; the problem and message in the log occurs always when the program try to update.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: setifaceUpdatePackages() failed
« Reply #4 on: January 14, 2008, 06:06:09 PM »
Which is your avast (program) version?
The best things in life are free.

Forejt

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #5 on: January 14, 2008, 06:19:17 PM »
Please send me files error.log and warning.log from avast4\data\logs folder, and setup.log from avast4\setup folder.

magostoni

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #6 on: January 14, 2008, 06:48:42 PM »
Here are the files you asked me; setup.log was too big so I cut the last piece.

With thanks


Forejt

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #7 on: January 14, 2008, 07:15:43 PM »
Does the file setup.ovr exist in avast4\setup folder? Or can you access Add/remove programs control panel -> avast! Antivirus?

magostoni

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #8 on: January 14, 2008, 07:23:53 PM »
Setup.ovr doesn't exist; exist setiface.ovr;

Yes I can access control panel -> change/remove Avast! Server edition.


Forejt

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #9 on: January 14, 2008, 07:33:41 PM »
Is there also file "avast.setup"? If yes, try to copy this file as "setup.ovr" and the problem should be fixed.

magostoni

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #10 on: January 14, 2008, 07:45:00 PM »
I copied and renamed avast.setup in setup.ovr then Try to update from menu Updating -> iAVS Update and receive a different error message

Function setifaceUpdatePackages() has failed. Return code is 0x00000426, dwRes is 00000000.

So what does has changed?

A note: avast.setup was 0 kb

Forejt

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #11 on: January 14, 2008, 08:11:14 PM »
Setup.ovr that is the main updating part was corrupted.
Download the file here (only for your server edition version 4.7.859):
http://public.avast.com/~forejt/av_srv-35b/setup.zip
Extract setup.ovr to avast4\setup folder, and delete avast.setup.
Then try the update again.

magostoni

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #12 on: January 15, 2008, 02:27:04 PM »
Ok,
now is working


Thanks a lot

mahatma2008

  • Guest
Re: setifaceUpdatePackages() failed
« Reply #13 on: April 03, 2008, 10:50:45 PM »
hi

i have the same problem ,but iam using the new avast 4.8.1169 home edition

and i do not know what to do

please help me

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: setifaceUpdatePackages() failed
« Reply #14 on: April 03, 2008, 10:58:27 PM »
i have the same problem ,but iam using the new avast 4.8.1169 home edition
Did you upgrade from 4.7 or this is a new installation?
Which antivirus did you use before avast?
From where were you download avast setup to install? Official site?
The best things in life are free.