Author Topic: Auto-update interval ignored  (Read 21394 times)

0 Members and 1 Guest are viewing this topic.

Offline JohnnyBob

  • Sr. Member
  • ****
  • Posts: 208
  • Peace
Re: Auto-update interval ignored
« Reply #30 on: January 21, 2012, 02:15:52 PM »
You're pushing this over the top. So good bye, and good luck! :)
BARE BONES installation of free avast! 2014.9.0.2021 with File System Shield (only). All "extras" are not installed or disabled. It wanted server status which I blocked via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox & IE8, Outlook Express, Thunderbird.

Offline Jack 1000

  • Poster
  • *
  • Posts: 619
Re: Auto-update interval ignored
« Reply #31 on: January 21, 2012, 09:12:04 PM »
I don't understand why the OP would not want the latest protection available?  I would seriously switch back to the default settings for Auto Definitions Update at least.  Otherwise, based on what the OP has said, he could have an infected computer that could be prevented with proper daily updates.

If the OP works for a company, and finds the voice distracting when an update occurs, a virus, or suspicious file is found, why not just disable Sounds in Avast settings?  If the OP finds the update pop-up distracting, you can also disable the pop-up from occurring in Avast Settings, but still stay protected.

The OP is putting his security at risk with his settings as he currently has them.

Jack
Avast 2014 -Windows XP (SP-3) and Malware Bytes Anti-Malware (Free Version)
1GB RAM

Offline JohnnyBob

  • Sr. Member
  • ****
  • Posts: 208
  • Peace
Re: Auto-update interval ignored
« Reply #32 on: January 21, 2012, 10:18:35 PM »
Jack,
I don't want frequent avast updates because it interrupts various sensitive software which I run frequently such as burning DVDs. Also I'm not always online and don't want interruptions when I'm working offline. I'm not so worried about viruses as some because I practice safe hex. I've never had a virus in the 30+ years I've been computing, insofar as I'm aware. So I believe that it is only a remote possibility that I'll catch a virus, and am confident that updating avast every few days is more than sufficient for my protection. But if it happens, it happens, which is not the end of the world. I'll deal with it then.

Bottomline: my computer, my risk.
BARE BONES installation of free avast! 2014.9.0.2021 with File System Shield (only). All "extras" are not installed or disabled. It wanted server status which I blocked via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox & IE8, Outlook Express, Thunderbird.

Offline DJBone

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6330
Re: Auto-update interval ignored
« Reply #33 on: January 21, 2012, 10:52:53 PM »
Why don't you use manual update?  ??? It seems the best solution for you.

DJBone
Win10 x64, AIS 20.1.2397
Avast Mobile Security (always latest version)

Offline JohnnyBob

  • Sr. Member
  • ****
  • Posts: 208
  • Peace
Re: Auto-update interval ignored
« Reply #34 on: January 21, 2012, 11:30:08 PM »
Why don't you use manual update?  ??? It seems the best solution for you.

DJBone
I did for awhile but it got to be too much trouble, and I sometimes forgot. So I appreciate having autoupdates as long as they're reliable as set. The time interval varies somewhat depending on how I use a particular computer.  Something in the 1-3 days range is usually OK. I don't mind more frequent updates on peripheral computers in my network, where I can just set it and forget it. But I want it much less frequently on my master network control computer where I do all the sensitive-software kind of work which shouldn't be interrupted.
BARE BONES installation of free avast! 2014.9.0.2021 with File System Shield (only). All "extras" are not installed or disabled. It wanted server status which I blocked via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox & IE8, Outlook Express, Thunderbird.

Offline DJBone

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6330
Re: Auto-update interval ignored
« Reply #35 on: January 21, 2012, 11:36:22 PM »
My solution for you: update for example every monday, wednesday and friday and deactivate auto-update. Then you can control it best.

DJBone
« Last Edit: January 21, 2012, 11:44:12 PM by DJBone »
Win10 x64, AIS 20.1.2397
Avast Mobile Security (always latest version)

Offline JohnnyBob

  • Sr. Member
  • ****
  • Posts: 208
  • Peace
Re: Auto-update interval ignored
« Reply #36 on: January 22, 2012, 12:00:35 AM »
My solution for you: update for example every monday, wednesday and friday and deactivate auto-update. Then you can control it best.

DJBone
Alas I don't always observe a traditional daily calendar. I'm always aware of the seasons (Spring Summer Autumn Winter) and the equinoxes, which are most important to me. But that doesn't seem quite often enough, updating just 4x per year. :)
BARE BONES installation of free avast! 2014.9.0.2021 with File System Shield (only). All "extras" are not installed or disabled. It wanted server status which I blocked via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox & IE8, Outlook Express, Thunderbird.

Offline DJBone

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6330
Re: Auto-update interval ignored
« Reply #37 on: January 22, 2012, 12:22:56 AM »
Alas I don't always observe a traditional daily calendar. I'm always aware of the seasons (Spring Summer Autumn Winter) and the equinoxes, which are most important to me. But that doesn't seem quite often enough, updating just 4x per year. :)
Alternative solution: update every sunrise. Unfortunately that is every day.

DJBone

PS: This isn't a joke! I really try to give you a solution.
Love, Peace and Happiness  :)
Win10 x64, AIS 20.1.2397
Avast Mobile Security (always latest version)

Offline BulmaSoft

  • Jr. Member
  • **
  • Posts: 40
Re: Auto-update interval ignored
« Reply #38 on: January 23, 2012, 04:50:20 PM »
Maybe there's a limit(?) and your 7 days setting is too long(?).

You might try my 3 days (4320 minutes) update interval setting and see if it works for you. I'm not sure. I reboot my computer frequently which resets all timers, and never seem to find the time to test it carefully.

@BulmaSoft,

The above is the most probable reason. Start by changing 240 minutes to 300. This means:

"Attempt to check if there is a definitions' update available every 5 hours, starting from reboot. If the system is rebooted, the timer starts again from zero."

With that setting, if you don't restart your system for, say, 16 hours, then avast will attempt to verify if there is an update available 3 times (once every 5 hours from your last reboot). If that works, change it again from 300 to 360, save the setting and test again (starting from a reboot after saving the new setting). You get the point.


I didn't know that restarting or rebooting the computer would matter in this subject!

I thought that Avast keeps record of time (time and date) of it's last successful update, and then "counts" the time interval in minutes until the next time for update...

So I didn't expect that a restart or power-off would "reset" that "timer"!

Thank You for Your answer, I get the point now! :)
Best regards!

P.S. In addition to previous discussion - here is how I worked my way around the "problem":
I switched Avast from "Auto" to "Manual" update.
Now it just pops-up to tell me that a new definition is available.
And when my computer is free (in CPU resources that is) then I click for it to perform an update.

Please note:
I too had no problems with viruses, and I run an old Pentium with 300Mhz CPU (!)
so the need of "saving the last free CPU resources" is the main reason why I was interested in this matter.
« Last Edit: January 23, 2012, 05:03:40 PM by BulmaSoft »

Offline JohnnyBob

  • Sr. Member
  • ****
  • Posts: 208
  • Peace
Re: Auto-update interval ignored
« Reply #39 on: January 23, 2012, 05:18:00 PM »
I too had no problems with viruses, and I run an old Pentium with 300Mhz CPU (!)
so the need of "saving the last free CPU resources" is the main reason why I was interested in this matter.
Glad you found a solution.

Same here, I have an older computer where resources are always stretched thin. Those with slow connections to the internet may also want to minimize downloads.

BARE BONES installation of free avast! 2014.9.0.2021 with File System Shield (only). All "extras" are not installed or disabled. It wanted server status which I blocked via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox & IE8, Outlook Express, Thunderbird.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Auto-update interval ignored
« Reply #40 on: January 23, 2012, 06:15:25 PM »
Quote
switched Avast from "Auto" to "Manual" update.
Now it just pops-up to tell me that a new definition is available.

Well, not exactly. The "automatic" option is the one showing you the tray notification and also updating.

The option that only pops up a tray notification is "ask", not "manual". "Manual" won't show you anything, no notification, no attempts to update (unless you manually take the action to update).

As said, if you set the frequency to 720 minutes (12 hours) in "automatic", you will have one automatic attempt for one actual update (as the definitions are usually updated twice a day in avast's servers, or more if needed), starting from boot time.

This means that your CPU won't be influenced at all (not even for tray notifications) during 12 hours after you boot.

To be clear, I'm not recommending any of these changes. I am just answering to your questions with several possible alternatives.

Unfortunately, avast doesn't have a way to set specific time of the day, or days of the week to allow (or force) updates (but the resources used for definitions updates are usually low and/or short in time anyway).
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline BulmaSoft

  • Jr. Member
  • **
  • Posts: 40
Re: Auto-update interval ignored
« Reply #41 on: January 23, 2012, 08:45:46 PM »
Ouch, sorry, yes I stand corrected - it is "ask" (not "manual")
I made an error typing my previous post.

I understand what You are suggesting me, but the main reason why it is not practical for me to have the "Automatic" option set at any given time interval is because it will always attempt to update itself a few minutes right after computer boot itself!
And when I power on my computer I need it as soon as possible...
So that is probably the worst time for Avast to perform anything! :)
It would be really the best solution for me to have the option to perform the update in after "X" minutes AFTER computer boot...

P.S. Can I use Window's scheduled task utility to update my Avast (?)
Can it be done by maybe creating some BAT file, or perhaps a script of some kind, and then to be launched by Windows Scheduled Task utility?

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 83537
  • No support PMs thanks
Re: Auto-update interval ignored
« Reply #42 on: January 23, 2012, 09:48:06 PM »
Then it would be best delay the first update check (not extend the subsequent checks duration):
- In avast6 you need to edit (using notepad) avast5.ini the [InetWD] section of the C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\avast5.ini (XP file location). Location for Vista, win7, C:\ProgramData\Alwil Software\Avast5\avast5.ini.
If you did a clean install of avast6 the folder names are slightly different, \Avast Software\Avast\ instead of \Alwil Software\Avast5\ other than that it is the same procedure.

- Broadband connections, add this line:
AlwaysConnectedWaitSeconds=120 and
AssumeAlwaysConnected=1 if not present (or edit AssumeAlwaysConnected=0 to AssumeAlwaysConnected=1)
Quote
[InetWD]
AssumeAlwaysConnected=1
AlwaysConnectedWaitSeconds=120
When complete save the changes, avast's self-defence module will ask for confirmation, etc. answer Yes.

The figure is seconds and the above equates to two minutes, you could try that and adjust upwards if required, 180, 240, etc. With an old system it may be better to set the delay to 5 or even 10 minutes (300
or 600) to give it a chance to complete the boot and stabilise.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.6.2420 (build 20.6.5495.561) UI-1.0.541/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline JohnnyBob

  • Sr. Member
  • ****
  • Posts: 208
  • Peace
Re: Auto-update interval ignored
« Reply #43 on: January 23, 2012, 11:55:16 PM »
I also mentioned that in my initial post that started this thread. Mine is set to wait 2 hours after bootup:

AlwaysConnectedWaitSeconds=7200

Only Notepad can be used to edit avast5.ini. Other text editors are rejected.
BARE BONES installation of free avast! 2014.9.0.2021 with File System Shield (only). All "extras" are not installed or disabled. It wanted server status which I blocked via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox & IE8, Outlook Express, Thunderbird.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Auto-update interval ignored
« Reply #44 on: January 24, 2012, 12:42:10 AM »
Just to complete the info provided by DavidR, that setting is for the first update after reboot ONLY and it is independent of the frequency talked about in previous posts (the 240 minutes default one).

In theory, the setting

Code: [Select]
[InetWD]
AssumeAlwaysConnected=1
AlwaysConnectedWaitSeconds=120

in the ini file (for a 120 seconds first delay) will delay the first update, but AFAIK the "definitions update" setting should be set to "automatic" too for it to work as intended.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?