Author Topic: HTTPS scanning blocking most sites (inc avast forum)  (Read 29781 times)

0 Members and 1 Guest are viewing this topic.

Closed account

  • Guest
HTTPS scanning blocking most sites (inc avast forum)
« on: November 03, 2014, 02:00:21 PM »
After 4 hours wondering why I was unable to log in to our website, view my homepage (https://www.google.co.uk/) or view this forum, I tracked it to avast's web shield. Specifically the https scanning.

So, my question is, what on earth is avast up to?

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #1 on: November 03, 2014, 03:15:13 PM »
HTTPS scanning was one thing several of us wanted. It enhances HTTPS security.
Before v2015 avast was not able to scan HTTPS connections.

To disable HTTPS scanning...GUI>Settings>Active Protection>Web Shield>click on "customize">untick the box  :)
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Closed account

  • Guest
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #2 on: November 03, 2014, 03:27:24 PM »
HTTPS scanning was one thing several of us wanted. It enhances HTTPS security.
Before v2015 avast was not able to scan HTTPS connections.

It is the extremely poor implementation I was talking about; blocking nearly all https connections (Google, my website, this forum, my bank etc. This was all in Firefox. Did they even test it?

On a side note, why does the site require a captcha for every post, when I am logged in (with HTTPS ironically)? The captcha takes 5 or 6 tries before I guess the correct characters (and each time i'm incorrect I lose what I've typed (unless I copy to clipboard first. The audio even has too much noise to be discernible. All very sloppy and unprofessional.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #3 on: November 03, 2014, 03:59:35 PM »
The captcha is for the first three posts.
HTTPS works fine here in both Firefox and Chrome.

What other security software do you have now or ever had?
If uninstalled how was it removed?
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Offline esm50

  • Newbie
  • *
  • Posts: 4
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #4 on: November 03, 2014, 05:09:37 PM »
Verified the same: "Page Cannot Be Displayed".  No warning from Avast 2015 that this is as a result from HTTPS Scanning.  Turning this feature off and site is good; again this is not for all HTTPS sites.

Also Avast 2015 Free is keeping this PC from entering Sleep Mode (S3).

Had to revert to V 2014 and all is well.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #5 on: November 03, 2014, 05:40:02 PM »
Verified the same: "Page Cannot Be Displayed".  No warning from Avast 2015 that this is as a result from HTTPS Scanning.  Turning this feature off and site is good; again this is not for all HTTPS sites.

Also Avast 2015 Free is keeping this PC from entering Sleep Mode (S3).

Had to revert to V 2014 and all is well.

Please start your own topic. Your set-up is not the same as the OP.
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Offline TheBlackOne

  • Newbie
  • *
  • Posts: 9
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #6 on: November 03, 2014, 06:25:14 PM »
I want to add some information about this isse from my side:

I am an employee of Electronic Arts, and I maintain the EA browser game "Command and Conquer - Tiberium Alliances".
Recently, we deactivated the SSLv3 protocol on all of our game hosts to avoid any security breaches by the POODLE attack, setting TLS 1.0 as the minimum SSL protocol.
After that, several users reported that they could not reach the game with any browser anymore, with the same error as the OP describes. It turned out, that this is caused by the Scan SSL feature in Avast (ESET has the same problem, btw). As soon as this feature is deactivated, the users can reach our game with every browser normally.

For reproduction, try to access the fowllowing URL with activated Scan SSL feature in Avast 2015.10.0.2206: https://prodgame07.alliances.commandandconquer.com/ with any browser.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #7 on: November 03, 2014, 06:39:45 PM »
Again, please start your own topic. Every system is different.
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #8 on: November 03, 2014, 06:55:27 PM »
Quote
For reproduction, try to access the fowllowing URL with activated Scan SSL feature in Avast 2015.10.0.2206: https://prodgame07.alliances.commandandconquer.com/ with any browser.
Works on windows 8.1, IE11 AIS 2015 all bells and whistles on :)  But I have disabled SSL 2.0 and SSL 3.0 in internet options

Offline TheBlackOne

  • Newbie
  • *
  • Posts: 9
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #9 on: November 03, 2014, 07:54:09 PM »
Again, please start your own topic. Every system is different.

Well, I have no problem, some of our users have. I am merely adding information and experience for this issue which seems to have the same root cause hoping that it can help to resolve the issue for everybody. If you can provide me with a way to contact the Avast developers directly, I would be happy to use it.
Apart from that, yes you are of course right: The relatively low number of complaining users tells me that there seems to be more factors involved to cause this problem. As soon as I know a perfect reproduction, I am more than happy to share my knowledge.

Offline TheBlackOne

  • Newbie
  • *
  • Posts: 9
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #10 on: November 03, 2014, 07:55:50 PM »
Quote
For reproduction, try to access the fowllowing URL with activated Scan SSL feature in Avast 2015.10.0.2206: https://prodgame07.alliances.commandandconquer.com/ with any browser.
Works on windows 8.1, IE11 AIS 2015 all bells and whistles on :)  But I have disabled SSL 2.0 and SSL 3.0 in internet options

Would you mind to give it a try with enabled SSLv3 in the Internet Options?

Offline esm50

  • Newbie
  • *
  • Posts: 4
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #11 on: November 03, 2014, 08:00:44 PM »
THIS IS THE TOPIC !

HTTPS Blocking:  Should be relevant to all  compatible hardware/software.  Should not need a new thread for every system difference .

Offline TheBlackOne

  • Newbie
  • *
  • Posts: 9
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #12 on: November 03, 2014, 08:27:55 PM »
From the german forum: The Scan SSL problem seems to be known, they are working on it: https://forum.avast.com/index.php?topic=158498.msg1144934#msg1144934

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #13 on: November 03, 2014, 08:48:07 PM »
Quote
Would you mind to give it a try with enabled SSLv3 in the Internet Options?
Still works, but as I only use IE I do not have any of the multitude of Firefox addons that other users have 

Offline KevTech

  • Jr. Member
  • **
  • Posts: 56
Re: HTTPS scanning blocking most sites (inc avast forum)
« Reply #14 on: November 03, 2014, 09:08:27 PM »
All sites work for me with https scanning enabled.

I am using Firefox 33.1 now but all sites worked when I was using 33.0.2 as well.

Only issue I had was Firefox crashing on exit which has been resolved.

May come down to some plugin issue.