Author Topic: Outlook toolbar issues: feedback needed  (Read 27172 times)

0 Members and 1 Guest are viewing this topic.

k.u.r.t

  • Guest
Outlook toolbar issues: feedback needed
« on: April 07, 2010, 03:06:05 PM »
Hi!
Recently it came to our attention that some of our users experience issues with our Outlook toolbar. These issues are either that the toolbar does not appear at all, the buttons are not enabled or the application crashes upon click a button. This build (5.0.492) contains a slightly augmented behaviour (which should hopefully work better) and also the possibility to log extra debug information which should enable us to pinpoint the root cause of the problem better.

Users that experience issues with our toolbar are advised to download the lates AIS beta and enable debug logging in Avast | Settings | Maintenance | Enable debug logging.
Restart Outlook and after experiencing you issue locate the log file and post it here together with the version number of your Outlook and a detailed description of the issue. Possibly attach a screenshot where appropriate.

The log file we are interested in can be located here:
C:\Documents And Settings\All Users\Application Data\Alwil Software\Avast5\Log\asOutExt.log (Windows 2000, Windows XP)
C:\ProgramData\Alwil Software\Avast5\Log\asOutExt.log (Windows Vista, Windows 7)

If you cannot see the path then you need to turn on the "Show hidden files and folders" option
Many thanks for your cooperation.
« Last Edit: April 09, 2010, 10:12:17 AM by k.u.r.t »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #1 on: April 07, 2010, 11:45:14 PM »
I've already done it: http://forum.avast.com/index.php?topic=57642.msg490486#msg490486
Right now I can't even enable the plugin.
But my mail is being scanned. So the problem is only the antispam part.
The best things in life are free.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #2 on: April 08, 2010, 09:32:45 AM »
Tech, thank you. I am really interested in asOutExt.log Are you sure you have the "Enable debug logging" check selected? From the log it looks like the first (and last) message is that the plugin started. Nothing afterwards. This is indeed very strange. Right after the "--- asoutext started ---" I exped to see the "OnStart" message, which should be invoked next, but I cannot see it. Neither do I see any error messages :-\ The most obviouos explanation is that you do not have the checkbox selected. The other explanation is that your avast and/or outlook installation is somehow corrupted (but this is not as likely). Do you have issues only on one computer or also on others? Any chance of you testing this and sending me the asoutext.log files? Many thanks.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #3 on: April 08, 2010, 08:12:42 PM »
Are you sure you have the "Enable debug logging" check selected?
In my reinstallations I've not checked that. Sorry.
Now it's checked. I'll try to enable the plugin and get the crash again.

Do you have issues only on one computer or also on others?
Well, I have only one AIS license and it's installed only in this computer.
The best things in life are free.

Cako

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #4 on: April 08, 2010, 08:40:35 PM »
The log file we are interested in can be located here:
C:\Documents And Settings\All Users\Alwil Software\Avast 5\Log\asOutExt.log (Windows 2000, Windows XP)
C:\ProgramData\Alwil Software\Avast 5\Log\asOutExt.log (Windows Vista, Windows 7)

in my winXP the path is:
C:\Documents and Settings\All Users\Application Data\Alwil Software\Avast5\log
You have to let the hidden files visible.

jmarti5

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #5 on: April 10, 2010, 05:13:51 AM »
Where can I download 5.0.492?  Can you provide a link?

Online NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5182
  • Whatever will be, will be.
Re: Outlook toolbar issues: feedback needed
« Reply #6 on: April 10, 2010, 05:18:54 AM »
Where can I download 5.0.492?  Can you provide a link?

See here:
http://forum.avast.com/index.php?topic=58183.0

5.0.499 (updated) is a pre-release (beta) version.
Main: Win10 Pro 21H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 22 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 21H1 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

slk2k

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #7 on: April 10, 2010, 05:14:23 PM »
OK - just updated to latest version of Avast IAS (5.0.499), enabled logging, restarted
and fired up Outlook 2007 (latest updates) running on a Windows 7 x64 Ultimate OS.
Opened 1st email, clicked down arrow in email to go trhough 3 emails, closed
email and *CRASH*.

Where do you want the log file uploaded to?  Or do you want it in line?

Nevermind - I uploaded it to ftp://ftp.avast.com/incoming and the file name
is slk2k_outlook2007_crash_AsOutExt.log.  Hope it helps.

(Edit - Added file location and cleaned up URL)
« Last Edit: April 10, 2010, 05:27:43 PM by slk2k »

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #8 on: April 12, 2010, 09:58:35 AM »
Wow, that looks indeed interesting. Many thanks for that one slk2k! I never even noticed those arrows there until you mentioned them. This issue has been fixed. Are there any differents incidents I need to be made aware of?

Tech, any success in bringing down your Outlook with buld 5.0.499 ? I modified the logs in that build to be more verbose around the area where your Outlook died last time.
« Last Edit: April 12, 2010, 01:27:25 PM by k.u.r.t »

isamuelson

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #9 on: April 12, 2010, 08:17:09 PM »
As soon as I applied this update, it fixed my issue and my tool bar showed up in Outlook.

However, it's stating that the latest version is 492-1 and it reports my version as 492-2 (or something like that). Is this normal because it keeps telling me my program files are out of date.

slk2k

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #10 on: April 12, 2010, 08:23:37 PM »
Wow, that looks indeed interesting. Many thanks for that one slk2k! I never even noticed those arrows there until you mentioned them. This issue has been fixed. Are there any different incidents I need to be made aware of?

Is there a new build to try?  I want to make sure whatever you fixed with this issue
isn't somehow manifesting itself in any new flaw I might find.  With a new build,
I'll give it proper shakedown ...  ;D

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #11 on: April 12, 2010, 09:07:30 PM »
Tech, any success in bringing down your Outlook with buld 5.0.499 ? I modified the logs in that build to be more verbose around the area where your Outlook died last time.
I already submitted to the ftp site. I can't enable the plugin without crashing Outlook.
What more do I need to do?
The best things in life are free.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #12 on: April 12, 2010, 10:25:20 PM »
What more do I need to do?
Try to repair the avast installation. alternatively you might try to "regsvr32 /u asoutext.dll" from the command line, restart outlook, followed by "regsvr32 asoutext.dll". That could work.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re: Outlook toolbar issues: feedback needed
« Reply #13 on: April 13, 2010, 04:27:07 AM »
What more do I need to do?
Try to repair the avast installation. alternatively you might try to "regsvr32 /u asoutext.dll" from the command line, restart outlook, followed by "regsvr32 asoutext.dll". That could work.
Doing so I can't activate the plugin anymore. I activate, restart Oulook, nothing (no toolbar and the plugin is disabled).
Even opening MS Outlook as admin to do so, it remains disabled (inactive)... :'(
The best things in life are free.

k.u.r.t

  • Guest
Re: Outlook toolbar issues: feedback needed
« Reply #14 on: April 13, 2010, 10:32:41 AM »
Please confirm that you tried the following sequence exactly as posted below:

1. Stop Outlook (check in the task manager whether OUTLOOK.EXE keeps running and kill it if necessary)
2. Start>Run>cmd
3. cd "\program files\alwil software\avast5\"
4. regsvr32 /u asoutext.dll
5. Start Outlook (the toolbar should NOT be visible and the plugin should NOT even be listed)
6. Stop Outlook (check in the task manager whether OUTLOOK.EXE keeps running and kill it if necessary)
7. regsvr32 asoutext.dll
8. Start Outlook (the toolbar might or might not be visible, and the plugin should be listed (hopefully not disabled))

Looking forward to seeing your results.