Author Topic: Firewall does not apply rules in "Ask" mode  (Read 11171 times)

0 Members and 1 Guest are viewing this topic.

Offline Michiro_Deviluke

  • Newbie
  • *
  • Posts: 3
Firewall does not apply rules in "Ask" mode
« on: April 06, 2020, 12:30:50 PM »
Hi,
since the last update firewall does not apply saved rules when it's configured to ask for what to do with new applications connecting to the Internet. It keeps asking whether I allow or deny connection to the Internet several times for each application (even for avast itself) after each reboot, system wake, etc. Of course I checked the option to "remember the setting for this app". There are rules on the application list, but firewall does not apply them.

I reinstalled avast, the situation happened again.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47431
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Firewall does not apply rules in "Ask" mode
« Reply #1 on: April 06, 2020, 07:58:55 PM »
Have you actually restarted the computer? Not down and start.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline Black_horse_88

  • Newbie
  • *
  • Posts: 10
Re: Firewall does not apply rules in "Ask" mode
« Reply #2 on: April 06, 2020, 11:48:07 PM »
Actually I've logged to post about this.
I'm having the same exact issue.

After the latest software update, Avast firewall keeps asking me about each connection every time I:
- Restart/shutdown PC.
- Re/connect to the internet.
- Disable and renabling Avast.

Despite having the rules saved as allow, it just keeps asking over and over.
And it's getting really annoying.
It's even asking me about Avast connections.

Uninstalled, then downloaded Avast and installed it again, still persist.

« Last Edit: April 06, 2020, 11:49:48 PM by Black_horse_88 »

Offline Michiro_Deviluke

  • Newbie
  • *
  • Posts: 3
Re: Firewall does not apply rules in "Ask" mode
« Reply #3 on: April 06, 2020, 11:52:35 PM »
Have you actually restarted the computer? Not down and start.


Of course I've restarted my computer, even twice, because I was reinstalling avast to see if this helps.

Offline HawkerEng

  • Jr. Member
  • **
  • Posts: 24
Re: Firewall does not apply rules in "Ask" mode
« Reply #4 on: April 07, 2020, 06:38:08 AM »
Same issue here. I had WireShark installed and it didn't remember anything. I uninstalled WireShark and now it remembers some settings, others it does not remember. I do not understand why it remembers some and not others.

Once I click what I want it seems to remember until I either Reboot, put the computer to sleep or disconnect/reconnect internet. Seems to still be a bug in this new version. a few threads here about it but no response from Avast like the last firewall bug yet.

So if you have WireShark, uninstall it and it will get better but not 100% fixed.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76118
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall does not apply rules in "Ask" mode
« Reply #5 on: April 07, 2020, 07:45:38 AM »
Hi guys, I forwarded it...
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline MartinK

  • Avast team
  • Jr. Member
  • *
  • Posts: 56
Re: Firewall does not apply rules in "Ask" mode
« Reply #6 on: April 07, 2020, 02:51:17 PM »
Thank you fo reporting the problem. Currently, we are trying to reproduce it and fix it.

Offline HawkerEng

  • Jr. Member
  • **
  • Posts: 24
Re: Firewall does not apply rules in "Ask" mode
« Reply #7 on: April 07, 2020, 03:54:52 PM »
@asyn or @MartinK

This morning I rebooted and I see I am now on 20.2.5130.566
While I still had the slow boot from log in screen issue I was only asked to repeat one "ask" firewall setting and not the large multiple list a reboot had caused before.

Can you speak of what was changed in .566 ovre .565. Asyn said .565 was to fix the can't turn on firewall bug. Was the permissions not sticking issue addressed in .566?

Either way if you are experiencing this problem try rebooting again and see if you are upgraded from .565 to .566

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76118
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall does not apply rules in "Ask" mode
« Reply #8 on: April 07, 2020, 04:10:44 PM »
Can you speak of what was changed in .566 ovre .565.
That's something for the devs to answer. ;)
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1885
    • AVAST Software
Re: Firewall does not apply rules in "Ask" mode
« Reply #9 on: April 07, 2020, 09:57:34 PM »
2HawkerEng: .566 modifies the upgrade process from 20.1 to 20.2. Boot time WFP rules from the previous version of the driver are now removed from the system right after the installation of the new driver, and not during the first aswnethub.sys run. Hope this helps.

Offline melodyig

  • Newbie
  • *
  • Posts: 2
Re: Firewall does not apply rules in "Ask" mode
« Reply #10 on: April 08, 2020, 06:49:13 PM »
I also have same issue since avast premium update on my system 3 or 4 days ago.   Hoping this gets resolved soon as turning off the firewall feature isn't a good option but the constant prompts are very frustrating.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47431
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Firewall does not apply rules in "Ask" mode
« Reply #11 on: April 08, 2020, 07:01:17 PM »
I also have same issue since avast premium update on my system 3 or 4 days ago.   Hoping this gets resolved soon as turning off the firewall feature isn't a good option but the constant prompts are very frustrating.
Have you tried to do an update manually?
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline mmgonzo

  • Newbie
  • *
  • Posts: 5
Re: Firewall does not apply rules in "Ask" mode
« Reply #12 on: April 08, 2020, 09:02:04 PM »
I am having the same issues on our Windows 7 Home pc.  Firewall asking to allow basic internet service functions; system, spool svc, Avast svc, Avast gui, pia-vpn, svchost, etc.  I did a repair function through Programs & Features; did not work.  I did a manual update through the system tray; did not work.  Resorting to the use of AvastClear uninstall utility.  This seems to happen to one of our pc's or laptops once a year.  Two hours later; frustrating.  Hopefully uninstall, CCleaner, and reinstall will work.   :'( :-[

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76118
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Firewall does not apply rules in "Ask" mode
« Reply #13 on: April 09, 2020, 05:51:57 AM »
As workaround, you can set the firewall to "auto-decide" for now.
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline HawkerEng

  • Jr. Member
  • **
  • Posts: 24
Re: Firewall does not apply rules in "Ask" mode
« Reply #14 on: April 09, 2020, 04:04:58 PM »
Asyn
That is not a safe or acceptable work around by any stretch of the imagination.

The issue is that Avasts "auto decide" decisions are way to lenient pretty much giving everything access when requested. Many many programs these days unnecessarily phone home, collect and and report back private information they don't need or spy on the users activities.  For this reason the firewall must be set to ask so we only enable applications that actually need to get to the internet.  As a general rule if the program can still run without internet then it doesn't need access and deny should be set.

This bug seems to go away for short periods giving me false home, but keeps coming back. It's really annoying. I wish we had some word from Avast when it will be patched. I feel we got an early Firewall Beta test not a working product which is really frustrating for such an important component to our security. Clearly this got let out before it was ready for prime time.

As workaround, you can set the firewall to "auto-decide" for now.