Author Topic: Mail scanner broken with today's update?  (Read 43097 times)

0 Members and 1 Guest are viewing this topic.

Offline petersboulton

  • Newbie
  • *
  • Posts: 11
Mail scanner broken with today's update?
« on: November 13, 2004, 11:52:07 AM »
Hi,
 My Avast program updated today to the following:

- Program: Already up to date
  (current version 4.5.517)
- Vps: Already up to date
  (current version 0446-2)

Now the internet mail scanner appears to be refusing a connection from my email client, even though I have not changed any settings there and verified that the settings are still correct.  When I take out Avast my email client connects to my mail servers just fine.

The message I get is "Could not connect to server 127.0.0.1; the connection was refused".  I am using Thunderbird email client (which is very nice!)

The Internet Mail Scanner is reported as being running and 'claims' to have scanned 3 messages since the update. I am confused, as they definitely did not get through to Thunderbird until I reverted to non Avast account settings in Thunderbird.

Anyone else noticed this problem, and any suggestions for fixing it?  It worked fine yesterday!

Thanks!

Pete

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Mail scanner broken with today's update?
« Reply #1 on: November 13, 2004, 11:55:43 AM »
Setup the email client as if Avast wasn't there. And let us know if the problem is solved.

Offline petersboulton

  • Newbie
  • *
  • Posts: 11
Re:Mail scanner broken with today's update?
« Reply #2 on: November 13, 2004, 12:08:24 PM »
I thought I had already confirmed I had done this in my original posting and that everything was then fine - i.e. "When I take out Avast my email client connects to my mail servers just fine."

Sorry if this was not clear!

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Mail scanner broken with today's update?
« Reply #3 on: November 13, 2004, 12:22:48 PM »
Quote
Could not connect to server 127.0.0.1; the connection was refused
Quote
It worked fine yesterday!
This indicates that the setup of Thunderbird for the mail is not correct.
Check your account settings and make sure they are as your mail provider tells you.

Offline focused

  • Newbie
  • *
  • Posts: 2
Re:Mail scanner broken with today's update?
« Reply #4 on: November 13, 2004, 12:31:03 PM »
I am also using Thunderbird with Avast, and have been for a year or so. They were working fine together up until today's update. Now I am getting the same error message as you reported 'Connection refused connecting to 127.0.0.1'

Note that if I uninstall Avast, and reinstall it works fine again. If I then update with todays update the error is back.

There is definetly nothing wrong with my Thunderbird settings. Seems to be a problem with this latest Avast update.

Offline HeX0R

  • Newbie
  • *
  • Posts: 3
Re:Mail scanner broken with today's update?
« Reply #5 on: November 13, 2004, 12:35:56 PM »
The same happened with incredimail ...

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Mail scanner broken with today's update?
« Reply #6 on: November 13, 2004, 12:39:44 PM »
1] Leave Avast 4.5.517 installed
2] Setup the email in your email client as instructed by your mail provider
3] Avast will take care of the rest (provided you use a email client Avast supports)

I've tested Avast 4.5.517 with TB, Incredimail, OE, Outlook and Opera, Avast has no problems with them.
« Last Edit: November 13, 2004, 12:40:25 PM by Eddy »

Offline Stevieboy

  • Newbie
  • *
  • Posts: 5
  • Senior Moment
Re:Mail scanner broken with today's update?
« Reply #7 on: November 13, 2004, 12:41:42 PM »
I know this one!!!

I know this one!!!

;D

The new update works transparently, so reset your email settings to work as if you *hadn't* got Avast installed.

You can check if Avast is scanning your email by either turning on the tray icon or checking the headers.

Not bad for a first post?

Offline HeX0R

  • Newbie
  • *
  • Posts: 3
Re:Mail scanner broken with today's update?
« Reply #8 on: November 13, 2004, 12:48:35 PM »
Yeah confirmed!
Maybe some kind of popup-information about this changes would have been useful ... ?

Offline focused

  • Newbie
  • *
  • Posts: 2
Re:Mail scanner broken with today's update?
« Reply #9 on: November 13, 2004, 01:03:10 PM »
Thanks - that fixed it for me too.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11808
    • AVAST Software
Re:Mail scanner broken with today's update?
« Reply #10 on: November 13, 2004, 02:08:51 PM »
Maybe some kind of popup-information about this changes would have been useful ... ?

Well, the settings should be updated automatically (without the user noticing). Seems like it didn't work in your case...

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Mail scanner broken with today's update?
« Reply #11 on: November 13, 2004, 02:10:39 PM »
It works automatically ONLY IF they were previously set up by the Mail Protection Wizard (which was not the case here - I believe...).

If you have set the servers (127.0.0.1 etc) manually, then you have to remove it manually.


Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

CoJo

  • Guest
Re:Mail scanner broken with today's update?
« Reply #12 on: November 13, 2004, 02:26:52 PM »
Hi everyone...

Before I touch a thing and posssibly mess things up...

After the update, I'm showing 7 providers total, 5 running. On Access Scanner says Internet Mail is waiting for a subsystem to start. Same for Outlook/Exchange
Obviously, I need some advice, please!

cojo

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Mail scanner broken with today's update?
« Reply #13 on: November 13, 2004, 02:32:23 PM »
Have you done as told in this thread by me, Igor and Vlk?

CoJo

  • Guest
Re:Mail scanner broken with today's update?
« Reply #14 on: November 13, 2004, 02:46:36 PM »
Eddy, my settings were done by the Mail Protection Wizard. If I remember correctly, some of the forum members had to help me get it set correctly (some time ago)

Do I need to do something manually now?

cojo