Author Topic: Mail scanner broken with today's update?  (Read 44055 times)

0 Members and 1 Guest are viewing this topic.

neal62

  • Guest
Re:Mail scanner broken with today's update?
« Reply #45 on: November 15, 2004, 12:00:34 AM »
The mail scanner feature with the new version of Avast 4.5 are definitely still functioning. At least they are on my pc, right Tipton? ;D

Tipton

  • Guest
Re:Mail scanner broken with today's update?
« Reply #46 on: November 15, 2004, 12:02:43 AM »
The mail scanner feature with the new version of Avast 4.5 are definitely still functioning. At least they are on my pc, right Tipton? ;D

Yes, and they are functioning on mine as well. You have to set it up in the mail provider options.

Tipton

S.Z.Craftec

  • Guest
Re:Mail scanner broken with today's update?
« Reply #47 on: November 15, 2004, 01:50:24 PM »
Petersboulton - what a huge avatar  ???

Here is the forum policy:

http://forum.avast.com/index.php?board=1;action=display;threadid=6339

Here is a quote:

Quote
do not use large pictures in signatures or avatars (mind other users who might have weaker connection and smaller display resolution)

Cheers !

trigger

  • Guest
Re:Mail scanner broken with today's update?
« Reply #48 on: November 16, 2004, 04:04:00 PM »
Ok, before I mess things up... Does this transparent mail checking make the The Bat! plugin obsolete???

Peter

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Mail scanner broken with today's update?
« Reply #49 on: November 16, 2004, 04:06:29 PM »
Not really. Bat users should probably use the plugin (the same applies to Outlook users) because it has certain advantages - protection of SSL-enabled accounts for example.

Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

trigger

  • Guest
Re:Mail scanner broken with today's update?
« Reply #50 on: November 16, 2004, 05:02:32 PM »
Ok, I'll keep using it then. Thanks.

Peter

Dancer_ge

  • Guest
Re:Mail scanner broken with today's update?
« Reply #51 on: November 21, 2004, 07:08:26 AM »
Hello, Vlk and you all.
I am any tech at all & am getting so confused on how to configure the eMail Scanner (in Avast!4.5) and Foxmail5. Ports and so, are the most xtrange thing for me about PCs.
Let me ask any of you give me clear (detailed as much as you can, sorry!) instructions on how to set them up, please. I have followed other related threads w/o getting the picture clear.
Account classes:
- ISP's POP
- My job's POP
- Hotmail's
- Yahoo's
Config:
- Windows me
- Kerio 2.5 PFw

Thanks a lot in advance for your help!

Will

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re:Mail scanner broken with today's update?
« Reply #52 on: November 21, 2004, 10:51:04 PM »
Has Avast discontinued using these lines? Or were the mails not scanned at all?

The have disapperaed from my incoming and outgoing email as well

No... The headers must be there. Your email are not being scanned  :'( :-\
The best things in life are free.

Fittie

  • Guest
Re:Mail scanner broken with today's update?
« Reply #53 on: November 23, 2004, 03:06:42 PM »
I sent a help message to support before looking at these forums, apologies.

I use Win XP Home, Mozilla & Zone Alarm Pro. After installing the latest edition of Avast I could not access my mail via 127.0.0.1. I changed my mail settings to the ISP account settings but of course mail was not being scanned.

I uninstalled Avast & reinstalled it. Did not seem to make any difference. Booted up the computer today & a pop up from Zone Alarm said that Avast email scanner wanted to access the internet. Ticked allow & the mail is now being scanned. No change to my email settings. Is 127.0.01 not necessart now?

S.Z.Craftec

  • Guest
Re:Mail scanner broken with today's update?
« Reply #54 on: November 23, 2004, 03:20:14 PM »
No, it's not necessary any more. Since the avast! version 4.5, mail handling is automatical. No need to set anything extra. Everybody using Windwos XP/NT should set their e-mail accounts just like avast! doesn't exist.

I'm glad you solved your problem now...

Cheers !

SupaSmurf

  • Guest
Re:Mail scanner broken with today's update?
« Reply #55 on: November 24, 2004, 02:42:09 AM »
Ok after having read and reread this thread I'm starting to wonder what's going on with my copy of Avast.

I've already tried Vik's 2 suggestions. The first of simply changing what ports are being configured in the mail client to up in the 12000 range. Didn't work. To confirm that, my firewall even states that Avast Mail Protection is currently set to listen on ports 25/110/143. I see nothing about the 12,000 range anywhere listed.

Secondly I tried just setting up the mail client to it's regular settings to see if the transparency would work. Multiple test e-mails all return without a trace of inbound or outbound scanning in the headers.

I'm at a loss. If anyone can give me a hand with this I would be much obliged.

Win2000 SP4
Avast 4.5 Home
Thunderbird 0.8
Hotmail Popper 3.0.2
YahooPOPs!
Sygate Personal Firewall 5.6

Thx in advance

S.Z.Craftec

  • Guest
Re:Mail scanner broken with today's update?
« Reply #56 on: November 24, 2004, 03:20:38 AM »
I'm not 100% sure, but I think that transparent mail scanner by default does not scan traffic between two programs that you are using on your PC. Those two are Thunderbird and Hotmail Popper. Try to enter these settings in avast4.ini file, under [MailScanner] section to enable scanning:

IgnoreLocalhost=0

In case you don't have [MailScanner] section in your avast4.ini file, just edit that file in some text editor, and add these lines:

[MailScanner]
IgnoreLocalhost=0


« Last Edit: November 25, 2004, 12:14:47 AM by S.Z.Craftec »

Rocket J Squirrel

  • Guest
Re:Mail scanner broken with today's update?
« Reply #57 on: November 24, 2004, 04:57:46 AM »
I, too, experience the "127.0.0.1 not responding" message today after Avast updated itself. (Win2K, Thunderbird 0.9). After a while I finally gave up trying to the the two mail providers to start in Avast, and told TB to directly access the POP servers. Which works fine. Reading this thread I am told that Avast no longer needs the 127.0.0.1 re-direction, and scans mail transparently.

I am not sure it is actually doing so -- I am used to seeing a notification in my e-mail message headers that Avast has found the mail to be clean.

None of the e-mails that I've received today have such a notation in the mail headers . . . . what's a good test to confirm that Avast is scanning my mails?

PS.  An earlier post suggests adding "IgnoreLocalhost=0" to the [MailScanner] section of my avast4.ini file, but there is no [MailScanner] section in my avast4.ini file

Spock

  • Guest
Re:Mail scanner broken with today's update?
« Reply #58 on: November 24, 2004, 05:43:48 AM »
Version 4.5 pro,  build 4.5.523 prevent sending E-mail with attachment with MS outlook express. Everything work O.K. with MS Outlook. If i terminate INTERNET MAIL in On Access protection controll then I can send e-mail with attachment normaly. Also
I have to notice, that this is happend on all computers not only on my.

S.Z.Craftec

  • Guest
Re:Mail scanner broken with today's update?
« Reply #59 on: November 24, 2004, 12:14:18 PM »
PS.  An earlier post suggests adding "IgnoreLocalhost=0" to the [MailScanner] section of my avast4.ini file, but there is no [MailScanner] section in my avast4.ini file

Well, create it in your avast4.ini file. Open it with your text editor and add these lines at the bottom:

[MailScanner]
IgnoreLocalhost=0


And this is how mine looks like:

[MailScanner]
DefaultPopServer=ORIGINALpopName.OF.My.MAIL.PROVIDER
DefaultSmtpServer=ORIGINALsmtpName.OF.My.MAIL.PROVIDER
ShowTrayIcon=1
UseDefaultSmtp=0
AutoSetProtection=0
PopListen=127.0.0.1:110
SmtpListen=127.0.0.1:25
ImapListen=127.0.0.1:143
StartPop=1
StartSmtp=1
StartImap=1

Do I have to repeat that you have to set your smtp and pop3 server names in your e-mail client just like avast! doesn't exist ? That includes pop3 and smtp server names, and your logging name and password (originals for each account you have). There are many threads covering this issue, and I'm kinda little tired typing this million times over and over again. I'm not trying to sound harsh on anyone, but it's very hard to follow all those posts and requests, especially considering that we already answered so many questions regarding same issue in some other threads. Please, use wonderful and very causy SEARCH feature in these forums to get more info (button is up there). Just type the key word and hit the search button.

How to properly set your mail provider, see by clicking on the link in my signature. That way you'll be sure that INSERT note into clean messages is enabled in avast! On Access Scanner / Internet Mail  provider...
« Last Edit: November 24, 2004, 12:31:11 PM by S.Z.Craftec »